summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-03-19 02:32:46 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-03-19 02:33:45 +0600
commitcced4ffac60e968488d5ba5b6c254a2ed3464c0c (patch)
tree1dee8d9bb744ddd773e2083cd913a12bdf6f02bb /sci-mathematics/mathmod/mathmod-4.1-r1.ebuild
parentapp-emulation/vmware-workstation: Remove old (diff)
downloadgentoo-cced4ffac60e968488d5ba5b6c254a2ed3464c0c.tar.gz
gentoo-cced4ffac60e968488d5ba5b6c254a2ed3464c0c.tar.bz2
gentoo-cced4ffac60e968488d5ba5b6c254a2ed3464c0c.zip
sci-mathematics/mathmod: install some useful files
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-mathematics/mathmod/mathmod-4.1-r1.ebuild')
-rw-r--r--sci-mathematics/mathmod/mathmod-4.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-mathematics/mathmod/mathmod-4.1-r1.ebuild b/sci-mathematics/mathmod/mathmod-4.1-r1.ebuild
new file mode 100644
index 000000000000..916862b09c17
--- /dev/null
+++ b/sci-mathematics/mathmod/mathmod-4.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils qmake-utils fdo-mime
+
+DESCRIPTION="Plot parametric and implicit surfaces"
+HOMEPAGE="https://www.facebook.com/pages/MathMod/529510253833102"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.zip"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtwidgets:5 dev-qt/qtopengl:5"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-branches-274-trunk
+
+src_configure() {
+ eqmake5 MathMod.pro
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe MathMod
+ insinto /usr/share/${P}
+ doins mathmodconfig.js mathmodcollection.js advancedmodels.js
+ newicon -s 16 icon/catenoid_mini_16x16.png catenoid.png
+ newicon -s 32 icon/catenoid_mini_32x32.png catenoid.png
+ newicon -s 64 icon/catenoid_mini_64x64.png catenoid.png
+ make_desktop_entry MathMod MathMod catenoid
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}