summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-01-31 23:30:19 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-01-31 23:30:19 +0700
commita00fbe6f10c9737ee8944de9df9d8c46931fc19e (patch)
tree16c1e2ffd6a659df10c03441afdd40a9c5d38cca /sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild
parentsci-mathematics/ginac: bump to 1.7.8 (diff)
downloadgentoo-a00fbe6f10c9737ee8944de9df9d8c46931fc19e.tar.gz
gentoo-a00fbe6f10c9737ee8944de9df9d8c46931fc19e.tar.bz2
gentoo-a00fbe6f10c9737ee8944de9df9d8c46931fc19e.zip
sci-mathematics/nestedsums: bump to 1.5.2
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild')
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild b/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild
new file mode 100644
index 000000000000..e0eff2517d56
--- /dev/null
+++ b/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
+HOMEPAGE="https://particlephysics.uni-mainz.de/weinzierl/nestedsums/"
+IUSE="doc"
+SRC_URI="http://particlephysics.uni-mainz.de/weinzierl/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sci-mathematics/ginac-1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen Doxyfile || die "generating documentation failed"
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${D}"usr/lib/*.la
+ dodoc AUTHORS ChangeLog
+
+ if use doc; then
+ dohtml reference/html/*
+ fi
+}