summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-02-07 14:30:22 -0500
committerMichael Orlitzky <mjo@gentoo.org>2023-02-07 14:31:47 -0500
commit6f6cb4f44bae2dc243cb8feb5adfa482f7081bbd (patch)
tree24be0b9026f07e172219f120bc483c361aa825e2 /sci-mathematics/primesieve
parentsci-mathematics/primesieve: stabilize 11.0 for amd64 (diff)
downloadgentoo-6f6cb4f44bae2dc243cb8feb5adfa482f7081bbd.tar.gz
gentoo-6f6cb4f44bae2dc243cb8feb5adfa482f7081bbd.tar.bz2
gentoo-6f6cb4f44bae2dc243cb8feb5adfa482f7081bbd.zip
sci-mathematics/primesieve: drop 8.0
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/primesieve')
-rw-r--r--sci-mathematics/primesieve/Manifest1
-rw-r--r--sci-mathematics/primesieve/primesieve-8.0.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index 2b5abb76ed6b..d61583c50cca 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1,2 +1 @@
DIST primesieve-11.0.tar.gz 125086 BLAKE2B ac425b6435bc95efbfc3d7458b59719af390508db811e0a993a606397166771cfcb9c0269249341fb6f678aafa8bae4a89e7a914176f61a608e6ccdfd0cab22b SHA512 1be9ff9d07068cab1ca69315010238ab15e5ba3b674bd45e9a0e11d20418810ece05a8df3853796118193468ac2ac6e24391f82d6db9581658ce59ddabb5b7fc
-DIST primesieve-8.0.tar.gz 119635 BLAKE2B e769cfe35752e809cf1611b3a9034bc79d16311c73d5065880cbec9c8179a2149ee9a3a6e277466691c44adf07781e1c7f9aa53f140714c4c9d408b24df17848 SHA512 213785c89868f224091fe76a74b98a896c374a7a96e2bdb44b07f4c6288bd50e22d9a563382fb512e71a1ad366d8b94e74fcc8b5f58bb94c85b4d435fbb6a571
diff --git a/sci-mathematics/primesieve/primesieve-8.0.ebuild b/sci-mathematics/primesieve/primesieve-8.0.ebuild
deleted file mode 100644
index 70bfdd3e99f2..000000000000
--- a/sci-mathematics/primesieve/primesieve-8.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="CLI and library for quickly generating prime numbers"
-HOMEPAGE="https://github.com/kimwalisch/primesieve"
-SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-SLOT="0/10" # subslot is first component of libprimesieve.so version
-KEYWORDS="amd64"
-IUSE="doc +executable test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
-DEPEND=""
-RDEPEND=""
-
-DOCS=(
- ChangeLog
- README.md
- doc/ALGORITHMS.md
- doc/CPP_API.md
- doc/C_API.md
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOC="$(usex doc)"
- -DBUILD_PRIMESIEVE="$(usex executable)"
- -DBUILD_STATIC_LIBS="OFF"
- -DBUILD_TESTS="$(usex test)"
- )
-
- if use doc; then
- DOCS+=(
- "${BUILD_DIR}/doc/html"
- "${BUILD_DIR}/doc/latex/refman.pdf"
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && cmake_build doc
-}