summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-21 23:22:14 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-22 00:54:00 +0100
commit335dfafb43cfb8574492617237712bcc324e980c (patch)
tree3e639098fed1359125f06c454b6f0c167e79056c /sci-mathematics
parentdev-lang/dafny-bin: bump to 3.12.0 (diff)
downloadgentoo-335dfafb43cfb8574492617237712bcc324e980c.tar.gz
gentoo-335dfafb43cfb8574492617237712bcc324e980c.tar.bz2
gentoo-335dfafb43cfb8574492617237712bcc324e980c.zip
sci-mathematics/stp: update PYTHON_COMPAT; add help2man to BDEPEND
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/stp/stp-2.3.3-r3.ebuild (renamed from sci-mathematics/stp/stp-2.3.3-r2.ebuild)28
1 files changed, 17 insertions, 11 deletions
diff --git a/sci-mathematics/stp/stp-2.3.3-r2.ebuild b/sci-mathematics/stp/stp-2.3.3-r3.ebuild
index 000e5bef36f9..3aa8309bf123 100644
--- a/sci-mathematics/stp/stp-2.3.3-r2.ebuild
+++ b/sci-mathematics/stp/stp-2.3.3-r3.ebuild
@@ -3,21 +3,26 @@
EAPI=8
-OC_H=119fe41a83bc455a24a11ecc9b78e7b13fcfcc45
-GT_H=2ad076167a676e3ed62f90b754b30fac5caa1f88
+OC_COMMIT=119fe41a83bc455a24a11ecc9b78e7b13fcfcc45
+GT_COMMIT=2ad076167a676e3ed62f90b754b30fac5caa1f88
-PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit flag-o-matic python-single-r1 cmake
DESCRIPTION="Simple Theorem Prover, an efficient SMT solver for bitvectors"
HOMEPAGE="https://stp.github.io/
https://github.com/stp/stp/"
-SRC_URI="https://github.com/stp/stp/archive/${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/stp/stp/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
test? (
- https://github.com/stp/OutputCheck/archive/${OC_H}.tar.gz -> ${P}_OutputCheck.tar.gz
- https://github.com/stp/googletest/archive/${GT_H}.tar.gz -> ${P}_gtest.tar.gz
- )"
+ https://github.com/stp/OutputCheck/archive/${OC_COMMIT}.tar.gz
+ -> ${P}_OutputCheck.tar.gz
+ https://github.com/stp/googletest/archive/${GT_COMMIT}.tar.gz
+ -> ${P}_gtest.tar.gz
+ )
+"
LICENSE="GPL-2+ MIT"
SLOT="0/${PV}"
@@ -38,7 +43,10 @@ RDEPEND="
python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-python/lit )"
+BDEPEND="
+ sys-apps/help2man
+ test? ( dev-python/lit )
+"
PATCHES=(
"${FILESDIR}"/${P}-CMakeLists.txt-fix_cflags.patch
@@ -46,8 +54,6 @@ PATCHES=(
"${FILESDIR}"/${P}-stp.py-library_path.patch
)
-#include <cstdint>
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -85,7 +91,7 @@ src_configure() {
CMAKE_BUILD_TYPE=Release
fi
- local mycmakeargs=(
+ local -a mycmakeargs=(
-DTEST_C_API=OFF # C API test fail
-DNOCRYPTOMINISAT=$(usex cryptominisat 'OFF' 'ON') # double negation
-DENABLE_PYTHON_INTERFACE=$(usex python)