summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-22 20:36:44 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-22 22:03:03 +0100
commit4b4456d612fa160bfbd974e2bf026daf733a8853 (patch)
tree192938e83cecc3de9e641c99640b167614d51ae4 /sci-mathematics
parenteutils.eclass: Add egit_clean() (diff)
downloadgentoo-4b4456d612fa160bfbd974e2bf026daf733a8853.tar.gz
gentoo-4b4456d612fa160bfbd974e2bf026daf733a8853.tar.bz2
gentoo-4b4456d612fa160bfbd974e2bf026daf733a8853.zip
sci-mathematics/rstudio: Use egit_clean to clean workdir
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/rstudio/rstudio-0.97.336.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.97.551.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.98.1028.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.98.1091.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.98.490-r1.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.98.490.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.98.932.ebuild10
-rw-r--r--sci-mathematics/rstudio/rstudio-0.98.953.ebuild10
-rw-r--r--sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.99.482.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.99.483.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.99.484.ebuild13
-rw-r--r--sci-mathematics/rstudio/rstudio-0.99.486.ebuild13
13 files changed, 100 insertions, 63 deletions
diff --git a/sci-mathematics/rstudio/rstudio-0.97.336.ebuild b/sci-mathematics/rstudio/rstudio-0.97.336.ebuild
index f473f63dd0fe..9b1726f92a22 100644
--- a/sci-mathematics/rstudio/rstudio-0.97.336.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.97.336.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,8 @@ GINVER=1.5
DESCRIPTION="IDE for the R language"
HOMEPAGE="http://www.rstudio.org"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GINVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWTVER}.zip
https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip"
@@ -29,7 +30,8 @@ IUSE="dedicated server"
QTVER=4.8
QTSLOT=4
-RDEPEND=">=dev-lang/R-2.11.1
+RDEPEND="
+ >=dev-lang/R-2.11.1
>=dev-libs/boost-1.50:=
dev-libs/mathjax
dev-libs/openssl:0
@@ -63,9 +65,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${P}-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${P}-prefs.patch \
"${FILESDIR}"/${P}-paths.patch \
"${FILESDIR}"/${P}-linker_flags.patch \
"${FILESDIR}"/${P}-boost-1.53.patch
diff --git a/sci-mathematics/rstudio/rstudio-0.97.551.ebuild b/sci-mathematics/rstudio/rstudio-0.97.551.ebuild
index f473f63dd0fe..9b1726f92a22 100644
--- a/sci-mathematics/rstudio/rstudio-0.97.551.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.97.551.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,8 @@ GINVER=1.5
DESCRIPTION="IDE for the R language"
HOMEPAGE="http://www.rstudio.org"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GINVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWTVER}.zip
https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip"
@@ -29,7 +30,8 @@ IUSE="dedicated server"
QTVER=4.8
QTSLOT=4
-RDEPEND=">=dev-lang/R-2.11.1
+RDEPEND="
+ >=dev-lang/R-2.11.1
>=dev-libs/boost-1.50:=
dev-libs/mathjax
dev-libs/openssl:0
@@ -63,9 +65,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${P}-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${P}-prefs.patch \
"${FILESDIR}"/${P}-paths.patch \
"${FILESDIR}"/${P}-linker_flags.patch \
"${FILESDIR}"/${P}-boost-1.53.patch
diff --git a/sci-mathematics/rstudio/rstudio-0.98.1028.ebuild b/sci-mathematics/rstudio/rstudio-0.98.1028.ebuild
index 52dc926b3bbb..261642427f8a 100644
--- a/sci-mathematics/rstudio/rstudio-0.98.1028.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.98.1028.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -21,9 +21,11 @@ PACKRAT_VER=0.3.0
RMARKDOWN_VER=0.2.49
DESCRIPTION="IDE for the R language"
-HOMEPAGE="http://www.rstudio.org
+HOMEPAGE="
+ http://www.rstudio.org
https://github.com/rstudio/rstudio/"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GINVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWTVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUMVER}.zip
@@ -93,9 +95,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${PN}-0.98.932-paths.patch \
"${FILESDIR}"/${PN}-0.98.932-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch
diff --git a/sci-mathematics/rstudio/rstudio-0.98.1091.ebuild b/sci-mathematics/rstudio/rstudio-0.98.1091.ebuild
index cdf98d37e9d2..906444e2d881 100644
--- a/sci-mathematics/rstudio/rstudio-0.98.1091.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.98.1091.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,9 +22,11 @@ RMARKDOWN_VER=0.98.1000
SHINYAPPS_VER=0.98.1000
DESCRIPTION="IDE for the R language"
-HOMEPAGE="http://www.rstudio.org
+HOMEPAGE="
+ http://www.rstudio.org
https://github.com/rstudio/rstudio/"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GINVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWTVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUMVER}.zip
@@ -102,9 +104,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${PN}-0.98.932-paths.patch \
"${FILESDIR}"/${PN}-0.98.1091-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch \
diff --git a/sci-mathematics/rstudio/rstudio-0.98.490-r1.ebuild b/sci-mathematics/rstudio/rstudio-0.98.490-r1.ebuild
index 898d7bf14097..d7b51f9ec0f9 100644
--- a/sci-mathematics/rstudio/rstudio-0.98.490-r1.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.98.490-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -16,7 +16,8 @@ GINVER=1.5
DESCRIPTION="IDE for the R language"
HOMEPAGE="http://www.rstudio.org"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GINVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWTVER}.zip
https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip"
@@ -28,7 +29,8 @@ IUSE=""
QTVER=4.8
QTSLOT=4
-RDEPEND=">=dev-lang/R-2.11.1
+RDEPEND="
+ >=dev-lang/R-2.11.1
>=dev-libs/boost-1.50:=
dev-libs/mathjax
dev-libs/openssl:0
@@ -59,9 +61,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${P}-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${P}-prefs.patch \
"${FILESDIR}"/${P}-paths.patch \
"${FILESDIR}"/${P}-linker_flags.patch
diff --git a/sci-mathematics/rstudio/rstudio-0.98.490.ebuild b/sci-mathematics/rstudio/rstudio-0.98.490.ebuild
index 7614e2491d84..d44e5fd89c5c 100644
--- a/sci-mathematics/rstudio/rstudio-0.98.490.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.98.490.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -16,7 +16,8 @@ GINVER=1.5
DESCRIPTION="IDE for the R language"
HOMEPAGE="http://www.rstudio.org"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GINVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWTVER}.zip
https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip"
@@ -28,7 +29,8 @@ IUSE="dedicated server"
QTVER=4.8
QTSLOT=4
-RDEPEND=">=dev-lang/R-2.11.1
+RDEPEND="
+ >=dev-lang/R-2.11.1
>=dev-libs/boost-1.50:=
dev-libs/mathjax
dev-libs/openssl:0
@@ -63,9 +65,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${P}-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${P}-prefs.patch \
"${FILESDIR}"/${P}-paths.patch \
"${FILESDIR}"/${P}-linker_flags.patch
diff --git a/sci-mathematics/rstudio/rstudio-0.98.932.ebuild b/sci-mathematics/rstudio/rstudio-0.98.932.ebuild
index a76aaada2957..25d85f426d71 100644
--- a/sci-mathematics/rstudio/rstudio-0.98.932.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.98.932.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -21,7 +21,8 @@ RMARKDOWN_VER=0.2.49
DESCRIPTION="IDE for the R language"
HOMEPAGE="http://www.rstudio.org"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GINVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWTVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUMVER}.zip
@@ -94,9 +95,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${P}-paths.patch \
"${FILESDIR}"/${P}-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch
diff --git a/sci-mathematics/rstudio/rstudio-0.98.953.ebuild b/sci-mathematics/rstudio/rstudio-0.98.953.ebuild
index 996d2f18d461..f9d1868d5f35 100644
--- a/sci-mathematics/rstudio/rstudio-0.98.953.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.98.953.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -21,7 +21,8 @@ RMARKDOWN_VER=0.2.49
DESCRIPTION="IDE for the R language"
HOMEPAGE="http://www.rstudio.org"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GINVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWTVER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUMVER}.zip
@@ -95,9 +96,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${PN}-0.98.932-paths.patch \
"${FILESDIR}"/${PN}-0.98.932-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch
diff --git a/sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild b/sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild
index 3682c5ca0fd0..64818de5367e 100644
--- a/sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.99.473-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,9 +26,11 @@ SHINYAPPS_VER=0.98.1000
RSCONNECT_VER=0.4.1.4_fcac892a69817febd7b655b189bf57193260cda0
DESCRIPTION="IDE for the R language"
-HOMEPAGE="http://www.rstudio.org
+HOMEPAGE="
+ http://www.rstudio.org
https://github.com/rstudio/rstudio/"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GIN_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWT_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUM_VER}.zip
@@ -123,9 +125,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${PN}-0.99.473-paths.patch \
"${FILESDIR}"/${PN}-0.99.473-clang-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch \
diff --git a/sci-mathematics/rstudio/rstudio-0.99.482.ebuild b/sci-mathematics/rstudio/rstudio-0.99.482.ebuild
index 3682c5ca0fd0..64818de5367e 100644
--- a/sci-mathematics/rstudio/rstudio-0.99.482.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.99.482.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,9 +26,11 @@ SHINYAPPS_VER=0.98.1000
RSCONNECT_VER=0.4.1.4_fcac892a69817febd7b655b189bf57193260cda0
DESCRIPTION="IDE for the R language"
-HOMEPAGE="http://www.rstudio.org
+HOMEPAGE="
+ http://www.rstudio.org
https://github.com/rstudio/rstudio/"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GIN_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWT_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUM_VER}.zip
@@ -123,9 +125,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${PN}-0.99.473-paths.patch \
"${FILESDIR}"/${PN}-0.99.473-clang-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch \
diff --git a/sci-mathematics/rstudio/rstudio-0.99.483.ebuild b/sci-mathematics/rstudio/rstudio-0.99.483.ebuild
index 3682c5ca0fd0..64818de5367e 100644
--- a/sci-mathematics/rstudio/rstudio-0.99.483.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.99.483.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,9 +26,11 @@ SHINYAPPS_VER=0.98.1000
RSCONNECT_VER=0.4.1.4_fcac892a69817febd7b655b189bf57193260cda0
DESCRIPTION="IDE for the R language"
-HOMEPAGE="http://www.rstudio.org
+HOMEPAGE="
+ http://www.rstudio.org
https://github.com/rstudio/rstudio/"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GIN_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWT_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUM_VER}.zip
@@ -123,9 +125,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${PN}-0.99.473-paths.patch \
"${FILESDIR}"/${PN}-0.99.473-clang-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch \
diff --git a/sci-mathematics/rstudio/rstudio-0.99.484.ebuild b/sci-mathematics/rstudio/rstudio-0.99.484.ebuild
index 3682c5ca0fd0..64818de5367e 100644
--- a/sci-mathematics/rstudio/rstudio-0.99.484.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.99.484.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,9 +26,11 @@ SHINYAPPS_VER=0.98.1000
RSCONNECT_VER=0.4.1.4_fcac892a69817febd7b655b189bf57193260cda0
DESCRIPTION="IDE for the R language"
-HOMEPAGE="http://www.rstudio.org
+HOMEPAGE="
+ http://www.rstudio.org
https://github.com/rstudio/rstudio/"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GIN_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWT_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUM_VER}.zip
@@ -123,9 +125,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${PN}-0.99.473-paths.patch \
"${FILESDIR}"/${PN}-0.99.473-clang-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch \
diff --git a/sci-mathematics/rstudio/rstudio-0.99.486.ebuild b/sci-mathematics/rstudio/rstudio-0.99.486.ebuild
index 3682c5ca0fd0..64818de5367e 100644
--- a/sci-mathematics/rstudio/rstudio-0.99.486.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.99.486.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -26,9 +26,11 @@ SHINYAPPS_VER=0.98.1000
RSCONNECT_VER=0.4.1.4_fcac892a69817febd7b655b189bf57193260cda0
DESCRIPTION="IDE for the R language"
-HOMEPAGE="http://www.rstudio.org
+HOMEPAGE="
+ http://www.rstudio.org
https://github.com/rstudio/rstudio/"
-SRC_URI="https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://s3.amazonaws.com/rstudio-buildtools/gin-${GIN_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/gwt-${GWT_VER}.zip
https://s3.amazonaws.com/rstudio-buildtools/selenium-java-${SELENIUM_VER}.zip
@@ -123,9 +125,10 @@ src_unpack() {
src_prepare() {
java-pkg-2_src_prepare
- find . -name .gitignore -delete || die
+ egit_clean
- epatch "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
"${FILESDIR}"/${PN}-0.99.473-paths.patch \
"${FILESDIR}"/${PN}-0.99.473-clang-pandoc.patch \
"${FILESDIR}"/${PN}-0.98.490-linker_flags.patch \