summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-24 11:28:23 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-24 11:28:58 +0100
commit86bbe6f24dd20ece2e429c187697c0a87c80df27 (patch)
treeda90829dbb87783d7708cf0d2d35a62b2f1f19dd /sci-mathematics
parentdev-games/godot: add 4.0_rc4 (diff)
downloadgentoo-86bbe6f24dd20ece2e429c187697c0a87c80df27.tar.gz
gentoo-86bbe6f24dd20ece2e429c187697c0a87c80df27.tar.bz2
gentoo-86bbe6f24dd20ece2e429c187697c0a87c80df27.zip
sci-mathematics/gsl-shell: add 2.3.5
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gsl-shell/Manifest1
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-2.3.5-no-fetching.patch64
-rw-r--r--sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild48
-rw-r--r--sci-mathematics/gsl-shell/metadata.xml3
4 files changed, 116 insertions, 0 deletions
diff --git a/sci-mathematics/gsl-shell/Manifest b/sci-mathematics/gsl-shell/Manifest
index 949bd19ffb3e..3c8d0e70418b 100644
--- a/sci-mathematics/gsl-shell/Manifest
+++ b/sci-mathematics/gsl-shell/Manifest
@@ -1 +1,2 @@
DIST gsl-shell-2.3.2.tar.gz 3400376 BLAKE2B 8218b4d3232048fe7575631c7acc66d313520ee4d41a1dd2c267f021c8271a427673a575cc00f8f55a4868b8ec5e9626c0cbaa6ea9fa76662a726e436a527cf3 SHA512 6379380ab15a7ec477d67d36305ce76c551d32e88d8611447eeb6deaf9877c362392bce45599a2b2988331064c22626260c41f8548624c23e2c4e3c59c87c291
+DIST gsl-shell-2.3.5.tar.gz 2533145 BLAKE2B 9eec5ee0676429a08b628766450f366b6998c4fc14e6b3108c49a9bf2ef4019c9b7671edbb0def295849155676df6c2bc8975aacb4ff906befc243bed147d80c SHA512 9712714a6cce249b007e475916d870eb2ce8bbc4ab2f0e49b8644378243723c9a386c285eacf5a8c54e27e22bab63fb0cd74d4641652230a8682c201b7e63da8
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-2.3.5-no-fetching.patch b/sci-mathematics/gsl-shell/files/gsl-shell-2.3.5-no-fetching.patch
new file mode 100644
index 000000000000..7ab67369b849
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-2.3.5-no-fetching.patch
@@ -0,0 +1,64 @@
+diff --git a/meson.build b/meson.build
+index 41f7e93..faf6e0d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -14,7 +14,7 @@ if host_machine.system() == 'darwin'
+ gsl_shell_defines += '-DDARWIN_MACOSX'
+ endif
+
+-gsl_shell_link_args = []
++gsl_shell_link_args = ['-laggplatformX11']
+ cc = meson.get_compiler('c')
+ if cc.get_id() == 'gcc' and get_option('buildtype') == 'release'
+ gsl_shell_link_args += ['-static-libgcc', '-static-libstdc++']
+@@ -25,19 +25,18 @@ cpp_utils_include = include_directories('src/cpp-utils')
+
+ threads_dep = dependency('threads')
+ freetype_dep = dependency('freetype2')
+-fox_dep = dependency('fox')
+-libagg_dep = dependency('libagg', fallback: ['libagg', 'libagg_dep'])
++fox_dep = dependency('fox17')
++libagg_dep = dependency('libagg', 'libaggplatformX11', fallback: ['libagg', 'libagg_dep'])
++libX11_dep = dependency('X11')
+
+-luajit_proj = subproject('luajit', default_options: ['default_library=static', 'app=false', 'portable=true', 'shortfnsyn=true'])
+-luajit_dep = luajit_proj.get_variable('lua_dep')
++luajit_dep = dependency('luajit')
+
+ libgsl_options = ['default_library=static', 'blas=' + get_option('blas')]
+ foreach module_name : ['siman', 'wavelet', 'sparse', 'ode', 'monte', 'integ', 'min', 'fit']
+ libgsl_options += module_name + '=false'
+ endforeach
+
+-libgsl_proj = subproject('gsl', default_options: libgsl_options)
+-libgsl_dep = libgsl_proj.get_variable('libgsl_dep').as_link_whole()
++libgsl_dep = dependency('gsl')
+
+ gsl_shell_bindir = 'bin'
+ gsl_shell_datadir = 'share/gsl-shell'
+diff --git a/src/console/meson.build b/src/console/meson.build
+index 2f5a3dc..3dfe7a5 100644
+--- a/src/console/meson.build
++++ b/src/console/meson.build
+@@ -1,7 +1,7 @@
+ # Readline not supported with meson build.
+
+ executable('gsl-shell', 'gsl-shell-jit.c',
+- dependencies: [libgsl_dep, libagg_dep, threads_dep, freetype_dep, luajit_dep],
++ dependencies: [libX11_dep, libgsl_dep, libagg_dep, threads_dep, freetype_dep, luajit_dep],
+ include_directories: gsl_shell_include,
+ cpp_args: gsl_shell_defines,
+ link_with: [libluagsl, libaggplot, libgdt],
+diff --git a/src/fox-gui/meson.build b/src/fox-gui/meson.build
+index 8f55259..fecefd7 100644
+--- a/src/fox-gui/meson.build
++++ b/src/fox-gui/meson.build
+@@ -13,7 +13,7 @@ foxgui_sources = [
+
+ executable('gsl-shell-gui',
+ foxgui_sources,
+- dependencies: [libgsl_dep, libagg_dep, threads_dep, freetype_dep, luajit_dep, fox_dep],
++ dependencies: [libX11_dep, libgsl_dep, libagg_dep, threads_dep, freetype_dep, luajit_dep, fox_dep],
+ include_directories: [gsl_shell_include, cpp_utils_include],
+ cpp_args: gsl_shell_defines + fox_gui_defines,
+ link_with: [libluagsl, libaggplot, libgdt],
diff --git a/sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild b/sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild
new file mode 100644
index 000000000000..aaa1e8873371
--- /dev/null
+++ b/sci-mathematics/gsl-shell/gsl-shell-2.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DOCS_BUILDER="sphinx"
+DOCS_DIR="doc/user-manual"
+DOCS_AUTODOC=0
+
+inherit meson python-any-r1 docs
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Lua interactive shell for sci-libs/gsl"
+HOMEPAGE="https://www.nongnu.org/gsl-shell/"
+SRC_URI="https://github.com/franko/gsl-shell/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=sci-libs/gsl-1.14:=
+ virtual/blas[eselect-ldso]
+ >=x11-libs/agg-2.5[X]
+ >=media-libs/freetype-2.4.10
+ sys-libs/readline:0=
+ || ( media-fonts/ubuntu-font-family media-fonts/freefont media-fonts/dejavu )
+ x11-libs/fox:1.7
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/luajit
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-fetching.patch"
+)
+
+src_compile() {
+ meson_src_compile
+ docs_compile
+}
diff --git a/sci-mathematics/gsl-shell/metadata.xml b/sci-mathematics/gsl-shell/metadata.xml
index 86a8f8253446..74456c83ce16 100644
--- a/sci-mathematics/gsl-shell/metadata.xml
+++ b/sci-mathematics/gsl-shell/metadata.xml
@@ -17,4 +17,7 @@ of easily access GSL functions without having to write a complete C application.
<use>
<flag name="fox">Build a <pkg>x11-libs/fox</pkg> GUI</flag>
</use>
+ <upstream>
+ <remote-id type="github">franko/gsl-shell</remote-id>
+ </upstream>
</pkgmetadata>