summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-05 01:10:45 +0100
committerSam James <sam@gentoo.org>2022-05-05 01:11:12 +0100
commitc9f89fde98fbb42678f1e168be438f99fe651473 (patch)
tree0c265bbc782519ccb502881dc10114dd61be70b0 /sci-mathematics
parentsci-mathematics/octave: style tweaks (diff)
downloadgentoo-c9f89fde98fbb42678f1e168be438f99fe651473.tar.gz
gentoo-c9f89fde98fbb42678f1e168be438f99fe651473.tar.bz2
gentoo-c9f89fde98fbb42678f1e168be438f99fe651473.zip
sci-mathematics/octave: use configure.ac patch
More resilient and doesn't get blown away by subsequent autoreconf. Bug: https://bugs.gentoo.org/839285 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/files/octave-7.1.0-omit-qtchooser-qtver.patch77
1 files changed, 18 insertions, 59 deletions
diff --git a/sci-mathematics/octave/files/octave-7.1.0-omit-qtchooser-qtver.patch b/sci-mathematics/octave/files/octave-7.1.0-omit-qtchooser-qtver.patch
index 3dc9c3e1d191..2b16fbf411e1 100644
--- a/sci-mathematics/octave/files/octave-7.1.0-omit-qtchooser-qtver.patch
+++ b/sci-mathematics/octave/files/octave-7.1.0-omit-qtchooser-qtver.patch
@@ -1,63 +1,22 @@
-diff -urNp octave-6.4.0-orig/configure octave-6.4.0-dwok/configure
---- octave-6.4.0-orig/configure 2022-04-19 20:45:23.112463584 +0200
-+++ octave-6.4.0-dwok/configure 2022-04-19 20:44:19.024774083 +0200
-@@ -77543,9 +77543,6 @@ esac
- fi
-
- if test -n "$MOC"; then
-- if test -n "$QTCHOOSER"; then
-- MOCFLAGS="-qt=$qt_version"
-- fi
- QT_TOOLS_AVAILABLE="$QT_TOOLS_AVAILABLE moc"
- else
- QT_TOOLS_MISSING="$QT_TOOLS_MISSING moc"
-@@ -77778,9 +77775,6 @@ esac
- fi
-
- if test -n "$UIC"; then
-- if test -n "$QTCHOOSER"; then
-- UICFLAGS="-qt=$qt_version"
-- fi
- QT_TOOLS_AVAILABLE="$QT_TOOLS_AVAILABLE uic"
- else
- QT_TOOLS_MISSING="$QT_TOOLS_MISSING uic"
-@@ -78013,9 +78007,6 @@ esac
- fi
-
- if test -n "$RCC"; then
-- if test -n "$QTCHOOSER"; then
-- RCCFLAGS="-qt=$qt_version"
-- fi
- QT_TOOLS_AVAILABLE="$QT_TOOLS_AVAILABLE rcc"
- else
- QT_TOOLS_MISSING="$QT_TOOLS_MISSING rcc"
-@@ -78248,9 +78239,6 @@ esac
- fi
-
- if test -n "$LRELEASE"; then
-- if test -n "$QTCHOOSER"; then
-- LRELEASEFLAGS="-qt=$qt_version"
-- fi
- QT_TOOLS_AVAILABLE="$QT_TOOLS_AVAILABLE lrelease"
- else
- QT_TOOLS_MISSING="$QT_TOOLS_MISSING lrelease"
-@@ -78483,9 +78471,6 @@ esac
- fi
-
- if test -n "$QCOLLECTIONGENERATOR"; then
+https://bugs.gentoo.org/839285
+--- a/m4/acinclude.m4
++++ b/m4/acinclude.m4
+@@ -2095,9 +2071,6 @@ AC_DEFUN([OCTAVE_CHECK_QT_TOOL], [
+ if test -z "$m4_toupper([$1])_QTVER"; then
+ AC_CHECK_TOOLS(m4_toupper([$1]), [$1])
+ if test -n "$m4_toupper([$1])"; then
- if test -n "$QTCHOOSER"; then
-- QCOLLECTIONGENERATORFLAGS="-qt=$qt_version"
+- m4_toupper([$1])FLAGS="-qt=$qt_version"
- fi
- QT_TOOLS_AVAILABLE="$QT_TOOLS_AVAILABLE qcollectiongenerator"
+ QT_TOOLS_AVAILABLE="$QT_TOOLS_AVAILABLE $1"
else
- QT_TOOLS_MISSING="$QT_TOOLS_MISSING qcollectiongenerator"
-@@ -78718,9 +78703,6 @@ esac
- fi
+ QT_TOOLS_MISSING="$QT_TOOLS_MISSING $1"
+@@ -2167,8 +2167,6 @@ AC_DEFUN([OCTAVE_CHECK_QT_VERSION], [AC_MSG_CHECKING([Qt version $1])
+ QT_TOOLS_MISSING=
- if test -n "$QHELPGENERATOR"; then
-- if test -n "$QTCHOOSER"; then
-- QHELPGENERATORFLAGS="-qt=$qt_version"
-- fi
- QT_TOOLS_AVAILABLE="$QT_TOOLS_AVAILABLE qhelpgenerator"
- else
- QT_TOOLS_MISSING="$QT_TOOLS_MISSING qhelpgenerator"
+ if test $build_qt_gui = yes; then
+- AC_CHECK_TOOLS(QTCHOOSER, [qtchooser])
+-
+ OCTAVE_CHECK_QT_TOOL([moc])
+ OCTAVE_CHECK_QT_TOOL([uic])
+ OCTAVE_CHECK_QT_TOOL([rcc])