summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:58:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:49 +0100
commitc8203f667c8cb7a44fea32d0c3f01c27a10029aa (patch)
tree357523c57396d7a705e3006feabaf1ab4e48aeb7 /sci-misc/vitables/vitables-3.0.0-r1.ebuild
parentsci-electronics/gresistor: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-c8203f667c8cb7a44fea32d0c3f01c27a10029aa.tar.gz
gentoo-c8203f667c8cb7a44fea32d0c3f01c27a10029aa.tar.bz2
gentoo-c8203f667c8cb7a44fea32d0c3f01c27a10029aa.zip
sci-misc/vitables: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-misc/vitables/vitables-3.0.0-r1.ebuild')
-rw-r--r--sci-misc/vitables/vitables-3.0.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-misc/vitables/vitables-3.0.0-r1.ebuild b/sci-misc/vitables/vitables-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..c25d11326d4c
--- /dev/null
+++ b/sci-misc/vitables/vitables-3.0.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+MY_P=ViTables-${PV}
+
+DESCRIPTION="A graphical tool for browsing / editing files in both PyTables and HDF5 formats"
+HOMEPAGE="http://vitables.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytables[${PYTHON_MULTI_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_MULTI_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ # remove the PyQt5 dependency
+ # because PyQt5 in Gentoo does not provide egg-info
+ # see also: https://github.com/pyqt/python-qt5/issues/18
+ sed "s:'PyQt5 [^ ]*::" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}