summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-12-12 21:10:14 +0100
committerGuilherme Amadio <amadio@gentoo.org>2021-12-14 15:58:24 +0100
commit544fcf2fbe461533e8842f380ffc8b5fce0a3ff0 (patch)
treef9c545cb598bd3e7de5727c3bd3b9415eac674bb /sci-physics/vmc/vmc-1.1_p1.ebuild
parentsci-physics/geant4_vmc: Bump to 5.4. (diff)
downloadgentoo-544fcf2fbe461533e8842f380ffc8b5fce0a3ff0.tar.gz
gentoo-544fcf2fbe461533e8842f380ffc8b5fce0a3ff0.tar.bz2
gentoo-544fcf2fbe461533e8842f380ffc8b5fce0a3ff0.zip
sci-physics/vmc: Bump to 1.1_p1.
Also, switch to EAPI 8. Closes: https://github.com/gentoo/gentoo/pull/23277 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/vmc/vmc-1.1_p1.ebuild')
-rw-r--r--sci-physics/vmc/vmc-1.1_p1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-physics/vmc/vmc-1.1_p1.ebuild b/sci-physics/vmc/vmc-1.1_p1.ebuild
new file mode 100644
index 000000000000..548f95349c9c
--- /dev/null
+++ b/sci-physics/vmc/vmc-1.1_p1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1-2 -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="The Virtual Monte Carlo core library"
+HOMEPAGE="https://vmc-project.github.io/ https://github.com/vmc-project/vmc"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="c++11 c++14 +c++17 doc"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+
+RDEPEND="sci-physics/root:=[c++11?,c++14?,c++17?,-vmc]"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.md History)
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ # TRAVIS_BUILD_DIR hardcoded in Doxyfile by upstream.
+ TRAVIS_BUILD_DIR="${S}" doxygen doc/doxygen/Doxyfile || die
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+}