summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-09-21 20:26:40 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-09-21 20:28:15 +0200
commit523a6a9001c4d54967def32909ce70cffd260093 (patch)
treeaa01ff1fdd75c828f7196b7365d992bd6f98c9f2 /sci-visualization
parentdev-db/mysql-workbench: remove unused patch (diff)
downloadgentoo-523a6a9001c4d54967def32909ce70cffd260093.tar.gz
gentoo-523a6a9001c4d54967def32909ce70cffd260093.tar.bz2
gentoo-523a6a9001c4d54967def32909ce70cffd260093.zip
sci-visualization/dash: disable testing
Closes: https://bugs.gentoo.org/814128 Closes: https://bugs.gentoo.org/810445 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/dash/dash-1.21.0.ebuild34
1 files changed, 8 insertions, 26 deletions
diff --git a/sci-visualization/dash/dash-1.21.0.ebuild b/sci-visualization/dash/dash-1.21.0.ebuild
index d50c7662e4b2..b41f8e0c29a3 100644
--- a/sci-visualization/dash/dash-1.21.0.ebuild
+++ b/sci-visualization/dash/dash-1.21.0.ebuild
@@ -14,39 +14,21 @@ SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# Test need some packages not yet in the tree
+# flask_talisman
+# percy
+# ...
+RESTRICT="test"
-DEPEND=""
-RDEPEND="${DEPEND}
+RDEPEND="
dev-python/future[${PYTHON_USEDEP}]
sci-visualization/dash-table[${PYTHON_USEDEP}]
sci-visualization/dash-html-components[${PYTHON_USEDEP}]
sci-visualization/dash-core-components[${PYTHON_USEDEP}]
dev-python/plotly[${PYTHON_USEDEP}]
dev-python/flask-compress[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup4 )"
BDEPEND=""
distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
- cd dash-renderer
- distutils-r1_src_prepare
-}
-
-src_configure() {
- distutils-r1_src_configure
- cd dash-renderer
- distutils-r1_src_configure
-}
-
-src_compile() {
- distutils-r1_src_compile
- cd dash-renderer
- distutils-r1_src_compile
-}
-
-src_install() {
- distutils-r1_src_install
- cd dash-renderer
- distutils-r1_src_install
-}