summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-07 13:44:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-07 14:52:28 +0200
commitc3876a84c08510d2351ee41d189e58f2592b8c77 (patch)
tree4753cc903efb5f5046f13718738cddb171ad2a32 /sci-visualization
parentsci-visualization/kst: EAPI-8 bump, switch to cmake.eclass (diff)
downloadgentoo-c3876a84c08510d2351ee41d189e58f2592b8c77.tar.gz
gentoo-c3876a84c08510d2351ee41d189e58f2592b8c77.tar.bz2
gentoo-c3876a84c08510d2351ee41d189e58f2592b8c77.zip
sci-visualization/kst: Fix build w/ >=dev-util/cmake-3.20
Closes: https://bugs.gentoo.org/778560 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/kst/files/kst-2.0.8-cmake-3.20.patch32
-rw-r--r--sci-visualization/kst/kst-2.0.8-r1.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-visualization/kst/files/kst-2.0.8-cmake-3.20.patch b/sci-visualization/kst/files/kst-2.0.8-cmake-3.20.patch
new file mode 100644
index 000000000000..39e2df7d0a64
--- /dev/null
+++ b/sci-visualization/kst/files/kst-2.0.8-cmake-3.20.patch
@@ -0,0 +1,32 @@
+From 6a41644c39ffb394c350de3dacbacdffa54a0a2a Mon Sep 17 00:00:00 2001
+From: Adriaan de Groot <groot@kde.org>
+Date: Sat, 3 Apr 2021 00:47:52 +0200
+Subject: [PATCH] Fix CMake-time with CMake 3.20
+
+Having multiple else-blocks for a single if() is now a syntax
+error; they need to be elseif() with only a single
+optional else() at the end.
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 593dcb11..f965bd64 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -116,10 +116,10 @@ elseif(kst_3rdparty_download)
+ elseif(GCC_VERSION VERSION_EQUAL 4.7 OR GCC_VERSION VERSION_GREATER 4.7)
+ set(ver 4.7)
+ set(md5 de6e8dbab1bb17eee6057941fddc93e3)
+- else(GCC_VERSION VERSION_EQUAL 4.6 OR GCC_VERSION VERSION_GREATER 4.6)
++ elseif(GCC_VERSION VERSION_EQUAL 4.6 OR GCC_VERSION VERSION_GREATER 4.6)
+ set(ver 4.6)
+ set(md5 70d8670af9c21eb8fb466654c95d8e4d)
+- else(GCC_VERSION VERSION_GREATER 4.4)
++ elseif(GCC_VERSION VERSION_GREATER 4.4)
+ set(ver 4.4)
+ set(md5 999248fb40a44543af4dd4cd1be0ceeb)
+ else()
+--
+GitLab
+
diff --git a/sci-visualization/kst/kst-2.0.8-r1.ebuild b/sci-visualization/kst/kst-2.0.8-r1.ebuild
index e7319cac8308..dea0db42382d 100644
--- a/sci-visualization/kst/kst-2.0.8-r1.ebuild
+++ b/sci-visualization/kst/kst-2.0.8-r1.ebuild
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}/${P}-includes.patch"
"${FILESDIR}/${P}-qt-5.11.patch"
"${FILESDIR}/${P}-gsl-2.0.patch"
+ "${FILESDIR}/${P}-cmake-3.20.patch" # bug 778560
)
src_configure() {