summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-17 23:14:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-18 23:32:33 +0100
commita8ad000f9169fb0633313f66c5d1c7397b1b8b4f (patch)
treeda46ef534f75bdb700026f1df75c9dafed311d0b /sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20210128.ebuild
parentMove {app-crypt → sec-keys}/openpgp-keys-alexbarton (diff)
downloadgentoo-a8ad000f9169fb0633313f66c5d1c7397b1b8b4f.tar.gz
gentoo-a8ad000f9169fb0633313f66c5d1c7397b1b8b4f.tar.bz2
gentoo-a8ad000f9169fb0633313f66c5d1c7397b1b8b4f.zip
Move {app-crypt → sec-keys}/openpgp-keys-bcl
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20210128.ebuild')
-rw-r--r--sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20210128.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20210128.ebuild b/sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20210128.ebuild
new file mode 100644
index 000000000000..014fb81c2480
--- /dev/null
+++ b/sec-keys/openpgp-keys-bcl/openpgp-keys-bcl-20210128.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenPGP keys used by Brian C. Lane"
+HOMEPAGE="https://www.brianlane.com/about-brian-c-lane/"
+SRC_URI="
+ https://www.brianlane.com/publickeys.txt -> bcl-publickeys.asc
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+S=${WORKDIR}
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - bcl.asc < <(cat "${files[@]/#/${DISTDIR}/}")
+}