summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-30 16:07:46 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-30 16:08:00 -0600
commit5470d0a54d0057cddb5352d9c438cf661e7e2430 (patch)
treebf04810e454833674617b04250370dcf3c028182 /sys-apps/bolt
parentdev-lang/go: 1.13.7 bump (diff)
downloadgentoo-5470d0a54d0057cddb5352d9c438cf661e7e2430.tar.gz
gentoo-5470d0a54d0057cddb5352d9c438cf661e7e2430.tar.bz2
gentoo-5470d0a54d0057cddb5352d9c438cf661e7e2430.zip
sys-apps/bolt: fix building with gcc-10
Closes: https://bugs.gentoo.org/706958 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-apps/bolt')
-rw-r--r--sys-apps/bolt/Manifest2
-rw-r--r--sys-apps/bolt/bolt-0.7.ebuild42
-rw-r--r--sys-apps/bolt/bolt-0.8-r1.ebuild (renamed from sys-apps/bolt/bolt-0.8.ebuild)9
3 files changed, 8 insertions, 45 deletions
diff --git a/sys-apps/bolt/Manifest b/sys-apps/bolt/Manifest
index 9a9183fe2ac4..9cb76e1b17ca 100644
--- a/sys-apps/bolt/Manifest
+++ b/sys-apps/bolt/Manifest
@@ -1,2 +1,2 @@
-DIST bolt-0.7.tar.gz 188158 BLAKE2B c51588ed746fd2aef15c79c278efe73e78ed8a029d2234b7a6ce717a6a3287ad0e9db82f93661c552a6a35c76a0e16a2712681f45e53f876b3b4f5bd839005b3 SHA512 6786f701501cc2680fac52cda7cdfe37971044abcf058b5c83bfa9f1d0a0381ba00e3377cfc97fcccf53760a2eafc1f8f6d0754f0e121d94201711ad8e40a135
DIST bolt-0.8.tar.gz 219317 BLAKE2B 9d76f3630d7f690c96447a894e54095deb7a19e46f2b02d7fbd9e584376d6b1a19391007a3a80e293adc8c9de6470279b587807d08006bbc12c7179bf0501e40 SHA512 0fdbc026178a4ca6a8c53aa46933d1c411eb04e350955f8b10c7faff814576d0796dd28e56b968648e549c79cf5fa13d43970d797595af0f66457abaef8ace09
+DIST bolt-210.patch 694 BLAKE2B 237d314aa8e4b1ed92931b5cef3079c23a55eca0cbb15038a92acf49b6563152229ff2bca8b9e30088d24a2ffb6c206dac5f3d73b69531182f0639675af36d56 SHA512 307b7c7efc18d2a22311e15e314604bd7d9721b18dfb8a3bab0e1147c3109c65313c3f7fe788431e64e6b26796b8a1da7f1963f9c2cdd8199d0f54349c2f60ce
diff --git a/sys-apps/bolt/bolt-0.7.ebuild b/sys-apps/bolt/bolt-0.7.ebuild
deleted file mode 100644
index 28823c01d33e..000000000000
--- a/sys-apps/bolt/bolt-0.7.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit meson systemd
-
-DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3."
-HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
-SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc systemd"
-
-DEPEND="
- >=dev-libs/glib-2.50.0:2
- dev-util/glib-utils
- virtual/libudev
- virtual/udev
- dev-util/umockdev
- sys-auth/polkit[introspection]
- systemd? ( sys-apps/systemd:0= )
- doc? ( app-text/asciidoc )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local emesonargs=(
- -Dman=$(usex doc true false)
- --sysconfdir=/etc
- --localstatedir=/var
- --sharedstatedir=/var/lib
- -Dsystemd=$(usex systemd true false)
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- keepdir /var/lib/boltd
-}
diff --git a/sys-apps/bolt/bolt-0.8.ebuild b/sys-apps/bolt/bolt-0.8-r1.ebuild
index 7adce26d5ac7..816710f173b7 100644
--- a/sys-apps/bolt/bolt-0.8.ebuild
+++ b/sys-apps/bolt/bolt-0.8-r1.ebuild
@@ -5,9 +5,10 @@ EAPI=6
inherit meson systemd
-DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3."
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
-SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz
+ https://gitlab.freedesktop.org/bolt/bolt/merge_requests/210.patch -> ${PN}-210.patch"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -25,6 +26,10 @@ DEPEND="
doc? ( app-text/asciidoc )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${DISTDIR}/${PN}-210.patch"
+)
+
src_configure() {
local emesonargs=(
-Dman=$(usex doc true false)