summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-09-29 09:30:28 -0500
committerBen Kohler <bkohler@gentoo.org>2022-09-29 09:32:42 -0500
commit39a29e71343141e6f58d2b3ac9f829da36ff09ec (patch)
tree0200adee034bb05f0586bff0cae7125359396484 /sys-apps/cpu-x
parentdev-db/pg_activity: remove old (diff)
downloadgentoo-39a29e71343141e6f58d2b3ac9f829da36ff09ec.tar.gz
gentoo-39a29e71343141e6f58d2b3ac9f829da36ff09ec.tar.bz2
gentoo-39a29e71343141e6f58d2b3ac9f829da36ff09ec.zip
sys-apps/cpu-x: only disable gsettings when USE=gui
This will fix an unused-cmake-var warning, this option is only meaningful when gtk support is on. Closes: https://bugs.gentoo.org/873418 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps/cpu-x')
-rw-r--r--sys-apps/cpu-x/cpu-x-4.4.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-apps/cpu-x/cpu-x-4.4.0.ebuild b/sys-apps/cpu-x/cpu-x-4.4.0.ebuild
index e1f02ebb7d26..c9667e5cef8d 100644
--- a/sys-apps/cpu-x/cpu-x-4.4.0.ebuild
+++ b/sys-apps/cpu-x/cpu-x-4.4.0.ebuild
@@ -53,7 +53,6 @@ S="${WORKDIR}/${MY_PN}-${PV}"
src_configure() {
local mycmakeargs=(
-DFORCE_LIBSTATGRAB=$(usex force-libstatgrab)
- -DGSETTINGS_COMPILE=OFF
-DWITH_GETTEXT=$(usex nls)
-DWITH_GTK=$(usex gui)
-DWITH_LIBCPUID=$(usex cpu)
@@ -63,6 +62,7 @@ src_configure() {
-DWITH_NCURSES=$(usex ncurses)
-DWITH_OPENCL=$(usex opencl)
)
+ use gui && mycmakeargs+=( -DGSETTINGS_COMPILE=OFF )
cmake_src_configure
}