summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 04:16:52 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:42 +0100
commit7c7f1bcbfbedf8181a40c6de460a15d9988de8cc (patch)
tree1f3d27f0b91756a4cc1443d693426c34e5683530 /sys-apps/man-db
parentapp-laptop/laptop-mode-tools: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-7c7f1bcbfbedf8181a40c6de460a15d9988de8cc.tar.gz
gentoo-7c7f1bcbfbedf8181a40c6de460a15d9988de8cc.tar.bz2
gentoo-7c7f1bcbfbedf8181a40c6de460a15d9988de8cc.zip
sys-apps/man-db: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Revbump because the new tmpfiles inherit adds a new dependency (virtual/tmpfiles). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/man-db-2.9.4-r1.ebuild (renamed from sys-apps/man-db/man-db-2.9.4.ebuild)4
-rw-r--r--sys-apps/man-db/man-db-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-apps/man-db/man-db-2.9.4.ebuild b/sys-apps/man-db/man-db-2.9.4-r1.ebuild
index ee7a1ac42db7..3bdd29d11b1a 100644
--- a/sys-apps/man-db/man-db-2.9.4.ebuild
+++ b/sys-apps/man-db/man-db-2.9.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd prefix
+inherit systemd prefix tmpfiles
DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
HOMEPAGE="http://www.nongnu.org/man-db/"
@@ -192,6 +192,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ tmpfiles_process man-db.conf
+
if [[ $(ver_cut 2 ${REPLACING_VERSIONS}) -lt 7 ]] ; then
einfo "Rebuilding man-db from scratch with new database format!"
su man -s /bin/sh -c 'mandb --quiet --create' 2>/dev/null
diff --git a/sys-apps/man-db/man-db-9999.ebuild b/sys-apps/man-db/man-db-9999.ebuild
index f5b961755735..66b83690c0b4 100644
--- a/sys-apps/man-db/man-db-9999.ebuild
+++ b/sys-apps/man-db/man-db-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd prefix
+inherit systemd prefix tmpfiles
DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
HOMEPAGE="http://www.nongnu.org/man-db/"
@@ -192,6 +192,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ tmpfiles_process man-db.conf
+
if [[ $(ver_cut 2 ${REPLACING_VERSIONS}) -lt 7 ]] ; then
einfo "Rebuilding man-db from scratch with new database format!"
su man -s /bin/sh -c 'mandb --quiet --create' 2>/dev/null