summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-26 12:50:26 +0000
committerSam James <sam@gentoo.org>2024-01-26 12:50:26 +0000
commit77f788b0982ac8c3239d4107deae1d5cee1cb5c2 (patch)
treed9094613ecd6e7b2d177ad0f195cfd07c7af280c /sys-apps/mawk/mawk-1.3.4_p20240123.ebuild
parentapp-arch/xz-utils: update LICENSE for docs for >=5.5.1_alpha (diff)
downloadgentoo-77f788b0982ac8c3239d4107deae1d5cee1cb5c2.tar.gz
gentoo-77f788b0982ac8c3239d4107deae1d5cee1cb5c2.tar.bz2
gentoo-77f788b0982ac8c3239d4107deae1d5cee1cb5c2.zip
sys-apps/mawk: add 1.3.4_p20240123
Closes: https://bugs.gentoo.org/881585 Closes: https://bugs.gentoo.org/908531 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/mawk/mawk-1.3.4_p20240123.ebuild')
-rw-r--r--sys-apps/mawk/mawk-1.3.4_p20240123.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/mawk/mawk-1.3.4_p20240123.ebuild b/sys-apps/mawk/mawk-1.3.4_p20240123.ebuild
new file mode 100644
index 000000000000..8e534e168e9a
--- /dev/null
+++ b/sys-apps/mawk/mawk-1.3.4_p20240123.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit toolchain-funcs verify-sig
+
+MY_P="${P/_p/-}"
+DESCRIPTION="An (often faster than gawk) awk-interpreter"
+HOMEPAGE="https://invisible-island.net/mawk/mawk.html"
+SRC_URI="https://invisible-mirror.net/archives/${PN}/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${MY_P}.tgz.asc )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-thomasdickey-20230810 )"
+
+DOCS=( ACKNOWLEDGMENT CHANGES README )
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ arc4random_push # doesn't exist on Linux
+)
+
+src_configure() {
+ tc-export BUILD_CC
+ econf
+}
+
+src_install() {
+ default
+
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk; then
+ eselect awk update ifunset
+ fi
+}
+
+pkg_postrm() {
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk; then
+ eselect awk update ifunset
+ fi
+}