summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCristian Othón Martínez Vera <cfuga@cfuga.mx>2022-06-25 04:44:00 +0100
committerSam James <sam@gentoo.org>2022-06-25 04:44:00 +0100
commit0773dc7048e4ce34e9d61c580a7424348f5124db (patch)
tree63852b143c2c3dacd5d4cf6771ffeb4b3a0c93b7 /sys-apps/pmount
parentnet-mail/dbmail: fix musl build (diff)
downloadgentoo-0773dc7048e4ce34e9d61c580a7424348f5124db.tar.gz
gentoo-0773dc7048e4ce34e9d61c580a7424348f5124db.tar.bz2
gentoo-0773dc7048e4ce34e9d61c580a7424348f5124db.zip
sys-apps/pmount: fix build with musl
Closes: https://bugs.gentoo.org/713422 Signed-off-by: Cristian Othón Martínez Vera <cfuga@cfuga.mx> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/files/pmount-0.9.99_alpha-limits-musl.patch12
-rw-r--r--sys-apps/pmount/pmount-0.9.99_alpha-r6.ebuild4
2 files changed, 14 insertions, 2 deletions
diff --git a/sys-apps/pmount/files/pmount-0.9.99_alpha-limits-musl.patch b/sys-apps/pmount/files/pmount-0.9.99_alpha-limits-musl.patch
new file mode 100644
index 000000000000..af6a1ebc521d
--- /dev/null
+++ b/sys-apps/pmount/files/pmount-0.9.99_alpha-limits-musl.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/713422
+--- a/src/utils.c
++++ b/src/utils.c
+@@ -25,6 +25,7 @@
+ #include <libintl.h>
+
+ #include <unistd.h>
++#include <limits.h>
+
+ #include "utils.h"
+
+
diff --git a/sys-apps/pmount/pmount-0.9.99_alpha-r6.ebuild b/sys-apps/pmount/pmount-0.9.99_alpha-r6.ebuild
index e6a575c9f139..1d336844462f 100644
--- a/sys-apps/pmount/pmount-0.9.99_alpha-r6.ebuild
+++ b/sys-apps/pmount/pmount-0.9.99_alpha-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,7 +26,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.9.19-testsuite-missing-dir.patch
"${FILESDIR}"/${P}-locale-regex.patch
"${FILESDIR}"/${P}-exfat-support.patch
-
+ "${FILESDIR}"/${P}-limits-musl.patch
)
src_prepare() {