summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-11 18:14:29 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-11 18:14:29 +0100
commit093ef5c35c81d33f11cc6f54927ff8098679c88c (patch)
treeb8bbd2d0be18b2ad2a8084aa32ad0559e04d05ef /sys-apps/superdiag
parentnet-vpn/tor: version bump to 0.4.6.10 (diff)
downloadgentoo-093ef5c35c81d33f11cc6f54927ff8098679c88c.tar.gz
gentoo-093ef5c35c81d33f11cc6f54927ff8098679c88c.tar.bz2
gentoo-093ef5c35c81d33f11cc6f54927ff8098679c88c.zip
sys-apps/superdiag: add 1.6.0.20211224
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/superdiag')
-rw-r--r--sys-apps/superdiag/Manifest1
-rw-r--r--sys-apps/superdiag/superdiag-1.6.0.20211224.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/superdiag/Manifest b/sys-apps/superdiag/Manifest
index 66577fe267d8..791223904d1c 100644
--- a/sys-apps/superdiag/Manifest
+++ b/sys-apps/superdiag/Manifest
@@ -1 +1,2 @@
DIST SuperDiag_1.5.0_20210507.zip 5039420 BLAKE2B bd249b7c2517857ce9079e3691cb31b3982dd097f11eb09288caff660d7f5e4a779519081cd27f89137d8173ad5419189122bc42bba5374f81f20c86f9e3e106 SHA512 ed457da1204b8670163f1186618b672cf088426461a1fb56c1bd618268e4f4420cd94bf05b62b3d6964499100583fe8ce72ced3ff8bafde3ac7db5c3ca0842e1
+DIST SuperDiag_1.6.0_20211224.zip 4669254 BLAKE2B b1b8c55d897bdcba219707a7bf76c802637215754291a78582c4d36441c375386b059ddbb8f27e7ad2cc0c86d9b68fdbea950120c8feed9e63c87a85f5d15181 SHA512 5559d3854d6a3f7ae6426a271b6bc8716ff9cf41c39f32fe23ee3cd2166946b778fe61b1f5ae8838efb2104b427423fa5b2a57c8734147478853290712ddea00
diff --git a/sys-apps/superdiag/superdiag-1.6.0.20211224.ebuild b/sys-apps/superdiag/superdiag-1.6.0.20211224.ebuild
new file mode 100644
index 000000000000..9d2a52f338f6
--- /dev/null
+++ b/sys-apps/superdiag/superdiag-1.6.0.20211224.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="SuperDiag"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Provides the capability to determine the health of Supermicro servers components"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_${MY_DATE}.zip"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+IUSE="iso usb"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=SDO"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+ unpack ${A}
+
+ if use iso; then
+ unzip Diagnose_Remotely/ISOFor${MY_PN}_${MY_PV}.zip -d iso || die
+ fi
+
+ if use usb; then
+ unzip Diagnose_Remotely/USBFor${MY_PN}_${MY_PV}.zip -d usb || die
+ fi
+}
+
+src_install() {
+ insinto /usr/share/superdiag
+ doins startup.nsh ${MY_PN}.efi EFI/Boot/BootX64.efi
+
+ local DOCS=(
+ "Supermicro Super Diagnostics Offline readme.txt"
+ "Supermicro Super Diagnostics Offline User Guide V${MY_PV}.pdf"
+ )
+ dodoc "${DOCS[@]}"
+
+ if use iso; then
+ insinto /usr/share/superdiag/ISO
+ doins iso/${MY_PN}_${MY_PV}.iso
+
+ newdoc iso/Readme.txt Readme.ISO.txt
+ fi
+
+ if use usb; then
+ insinto /usr/share/superdiag/USB
+ doins usb/startup.nsh
+
+ dosym ../BootX64.efi /usr/share/superdiag/USB/BootX64.efi
+ dosym ../${MY_PN}.efi /usr/share/superdiag/USB/${MY_PN}.efi
+
+ newdoc usb/Readme.txt Readme.USB.txt
+ fi
+}