summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-11-04 14:28:46 -0500
committerMike Gilbert <floppym@gentoo.org>2024-11-04 14:35:30 -0500
commit01dcfd54a65324f897507abf4faae1dba127e7d8 (patch)
tree38864dde44ca5ef6285511ff5e198019969e3f9b /sys-apps
parentdev-ruby/time: marked ~arm64-macos (diff)
downloadgentoo-01dcfd54a65324f897507abf4faae1dba127e7d8.tar.gz
gentoo-01dcfd54a65324f897507abf4faae1dba127e7d8.tar.bz2
gentoo-01dcfd54a65324f897507abf4faae1dba127e7d8.zip
sys-apps/sandbox: drop 2.37, 2.38
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/Manifest2
-rw-r--r--sys-apps/sandbox/sandbox-2.37.ebuild64
-rw-r--r--sys-apps/sandbox/sandbox-2.38.ebuild64
3 files changed, 0 insertions, 130 deletions
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 1b4119fa74ad..5fe192c04254 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,3 +1 @@
-DIST sandbox-2.37.tar.xz 459420 BLAKE2B 0f6c701f819139f557a5fccb59e67509b04ba6eb22e79250a69ae990b123f9f7b618bb82a43ea86e1b18614c38d0d884aceb77d17af5a92030b2b4ad89eb2bd4 SHA512 91ddb98aa118f2d606aaf64b20598dbed9239069350842ab9fd3af05b1942380c92841d044387bc2d761317faa9c44848b3010e18747d834c115929f64060056
-DIST sandbox-2.38.tar.xz 460776 BLAKE2B 39a93e77301d5b6ea0a352cf1dc7786a1030a3701b0f8beca62e80a4f0d614b26cb3764ecf0174a9fd77acf27ae5d972de352e6fdec5a169aba83e6146a84038 SHA512 a559e32654b2fd7baca70b85f6dbf0a610e5847ccf28d7a0536485aedbfb1ce8394a080e6efdafcf76e01439b2592eebcef6c8f77a976188ce7e3759a2844d3f
DIST sandbox-2.39.tar.xz 462796 BLAKE2B 330c6f896eba6ff2a38eb8a5d1ff9b242d0e42ab03734254b1851f36cc851c32e7ed3d32afe07374b6e264cb0a922d25b010af5269f60fc5142b9036008f0945 SHA512 5eed5d828eb904b15d52736ea8835128e805f0274f2152d033ae6d93f1df3bc1f50ed23d7544c37ee06b14cb2c301110730e1de3097d6f7032069ef8dbbbd28c
diff --git a/sys-apps/sandbox/sandbox-2.37.ebuild b/sys-apps/sandbox/sandbox-2.37.ebuild
deleted file mode 100644
index 10350e637a79..000000000000
--- a/sys-apps/sandbox/sandbox-2.37.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic multilib-minimal multiprocessing
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
-SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+nnp"
-
-# pax-utils lower bound for bug #265376
-DEPEND=">=app-misc/pax-utils-0.1.19"
-# Avoid folks installing with older file, bug #889046. We still need the
-# >= dep in Portage but this is a safety net if people do partial upgrades.
-RDEPEND="!<sys-apps/file-5.44-r1"
-BDEPEND="app-arch/xz-utils"
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS+=" sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-src_prepare() {
- default
-
- if ! use nnp ; then
- sed -i 's:PR_SET_NO_NEW_PRIVS:___disable_nnp_hack:' src/sandbox.c || die
- fi
-
- # sandbox uses `__asm__ (".symver "...` which does
- # not play well with gcc's LTO: https://gcc.gnu.org/PR48200
- filter-lto
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- ECONF_SOURCE="${S}" econf
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- dodoc AUTHORS ChangeLog* README.md
-}
-
-pkg_postinst() {
- mkdir -p "${EROOT}"/var/log/sandbox
- chown root:portage "${EROOT}"/var/log/sandbox
- chmod 0770 "${EROOT}"/var/log/sandbox
-}
diff --git a/sys-apps/sandbox/sandbox-2.38.ebuild b/sys-apps/sandbox/sandbox-2.38.ebuild
deleted file mode 100644
index 10350e637a79..000000000000
--- a/sys-apps/sandbox/sandbox-2.38.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic multilib-minimal multiprocessing
-
-DESCRIPTION="sandbox'd LD_PRELOAD hack"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
-SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+nnp"
-
-# pax-utils lower bound for bug #265376
-DEPEND=">=app-misc/pax-utils-0.1.19"
-# Avoid folks installing with older file, bug #889046. We still need the
-# >= dep in Portage but this is a safety net if people do partial upgrades.
-RDEPEND="!<sys-apps/file-5.44-r1"
-BDEPEND="app-arch/xz-utils"
-
-has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS+=" sandbox_death_notice"
-
-sandbox_death_notice() {
- ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
- ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
-}
-
-src_prepare() {
- default
-
- if ! use nnp ; then
- sed -i 's:PR_SET_NO_NEW_PRIVS:___disable_nnp_hack:' src/sandbox.c || die
- fi
-
- # sandbox uses `__asm__ (".symver "...` which does
- # not play well with gcc's LTO: https://gcc.gnu.org/PR48200
- filter-lto
-}
-
-multilib_src_configure() {
- filter-lfs-flags #90228
-
- ECONF_SOURCE="${S}" econf
-}
-
-multilib_src_test() {
- # Default sandbox build will run with --jobs set to # cpus.
- emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
-}
-
-multilib_src_install_all() {
- doenvd "${FILESDIR}"/09sandbox
-
- dodoc AUTHORS ChangeLog* README.md
-}
-
-pkg_postinst() {
- mkdir -p "${EROOT}"/var/log/sandbox
- chown root:portage "${EROOT}"/var/log/sandbox
- chmod 0770 "${EROOT}"/var/log/sandbox
-}