summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-28 01:01:44 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-28 01:03:02 +0100
commit589d208caede20cd24d0e071f13130370b6bda45 (patch)
tree3ef249fd71a0908237faca12b7540f81024cc533 /sys-apps
parentx11-misc/dunst: drop 1.7.3, 1.8.0 (diff)
downloadgentoo-589d208caede20cd24d0e071f13130370b6bda45.tar.gz
gentoo-589d208caede20cd24d0e071f13130370b6bda45.tar.bz2
gentoo-589d208caede20cd24d0e071f13130370b6bda45.zip
sys-apps/smc-sum-driver: last-rite
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smc-sum-driver/Manifest1
-rw-r--r--sys-apps/smc-sum-driver/files/makefile15
-rw-r--r--sys-apps/smc-sum-driver/metadata.xml13
-rw-r--r--sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r4.ebuild44
4 files changed, 0 insertions, 73 deletions
diff --git a/sys-apps/smc-sum-driver/Manifest b/sys-apps/smc-sum-driver/Manifest
deleted file mode 100644
index 75709223439a..000000000000
--- a/sys-apps/smc-sum-driver/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST sum_driver_V1.6.0_20151201.tar.gz 1423921 BLAKE2B 76e2439148749b708a51e0d9c95545b53762f03793e6b2ea6e63e9f79aaad77432f728e94713e0cfd4085e8b090b6e0ff8e779e2627764e71794453cb7e02b49 SHA512 809fdf164e29aabde74306d966de7e07488d8dacc01963b56486477f23bdf3a469d059bc5d302aedbfd4b8dc854a82357747add2626cc22d0ab3898c7bc0a625
diff --git a/sys-apps/smc-sum-driver/files/makefile b/sys-apps/smc-sum-driver/files/makefile
deleted file mode 100644
index 35564dcc8fec..000000000000
--- a/sys-apps/smc-sum-driver/files/makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-obj-m := sum_bios.o
-
-KVERSION := $(shell uname -r)
-KDIR := /lib/modules/$(KVERSION)/build
-PWD := $(shell pwd)
-
-EXTRA_CFLAGS = $(CFLAGS) -Wno-incompatible-pointer-types
-EXTRA_LDFLAGS = $(LDFLAGS)
-
-default:
- $(MAKE) -C $(KDIR) M=$(PWD) modules
-
-install:
- $(MAKE) -C $(KDIR) M=$(PWD) modules_install
-
diff --git a/sys-apps/smc-sum-driver/metadata.xml b/sys-apps/smc-sum-driver/metadata.xml
deleted file mode 100644
index bb0c0542a46a..000000000000
--- a/sys-apps/smc-sum-driver/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>conikost@gentoo.org</email>
- <name>Conrad Kostecki</name>
- </maintainer>
- <longdescription>
- This is the kernel module for the Supermicro Update Manager (SUM).
- It's needed to access specific low level elements, like BIOS.
- Supermicro SuperDoctor5 will also need this kernel module.
- </longdescription>
-</pkgmetadata>
diff --git a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r4.ebuild b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r4.ebuild
deleted file mode 100644
index cca00d6b3614..000000000000
--- a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-mod
-
-MY_DATE="$(ver_cut 4)"
-MY_PN="${PN//-/_}"
-MY_PV="$(ver_cut 1-3)"
-MY_P="${MY_PN/smc_/}_V${MY_PV}"
-
-DESCRIPTION="Supermicro Update Manager (SUM) kernel module"
-HOMEPAGE="https://www.supermicro.com"
-SRC_URI="${MY_P}_${MY_DATE}.tar.gz"
-S="${WORKDIR}/${MY_P}/Linux"
-
-KEYWORDS="-* amd64 x86"
-LICENSE="supermicro"
-SLOT="0"
-
-RESTRICT="bindist fetch mirror"
-
-BUILD_TARGETS="default"
-MODULE_NAMES="sum_bios(misc:${S})"
-
-pkg_nofetch() {
- elog "Please contact the Supermicro support at support@supermicro.com,"
- elog "in order to obtain a copy of ${A}"
- elog "and place it in your DISTDIR directory."
-}
-
-src_prepare() {
- default
-
- # Install new Makefile to respect users CFLAGS and LDFLAGS
- cp "${FILESDIR}"/makefile Makefile || die
-}
-
-src_compile() {
- BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
-
- linux-mod_src_compile
-}