summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-10-24 12:48:50 +0100
committerSam James <sam@gentoo.org>2021-10-31 02:50:21 +0000
commit625f42a5adbc3fc64bd0350596a293336f6b814e (patch)
tree44fb90911009fdf9d417b5a7e3b9a92bf652b65c /sys-apps
parentsys-apps/checkpolicy: Version updated to 3.3. (diff)
downloadgentoo-625f42a5adbc3fc64bd0350596a293336f6b814e.tar.gz
gentoo-625f42a5adbc3fc64bd0350596a293336f6b814e.tar.bz2
gentoo-625f42a5adbc3fc64bd0350596a293336f6b814e.zip
sys-apps/mcstrans: Version updated to 3.3.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mcstrans/Manifest1
-rw-r--r--sys-apps/mcstrans/mcstrans-3.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/mcstrans/Manifest b/sys-apps/mcstrans/Manifest
index fc5d2bd27eec..5317d4a5e332 100644
--- a/sys-apps/mcstrans/Manifest
+++ b/sys-apps/mcstrans/Manifest
@@ -1,2 +1,3 @@
DIST mcstrans-3.1.tar.gz 44598 BLAKE2B 1755c2f56e3d40fa2ea95c349988fe5dd7b52a9f26bef0f42e42bda8f7b94993b9a47d2e333337f746cbabd9dd571118b0a8e1ffb7c22c604db58fc809bcc033 SHA512 21e9b7a8c9d98cbee61f2eb1c440a51d19ac111a5955c24d365a8784e1aa34fb47a22a108e550c8a4cde4f25ec5afc466126a68e9faedfc796bef83eada93b60
DIST mcstrans-3.2.tar.gz 44596 BLAKE2B 6738acbcb7c25ec67b8d14cd166c601c7790d28332de8eb4caec32e43390b199aeea51750856aee7c4a2bcfc003af3ac01b00a4247578230d42de3956a88ebb2 SHA512 edc7d4c255056d823c67d69d0c0bb49e8da8cf1b69d94b65e1c2cb5f4944dcc0bd26ed795d76cbe310d9c98b98ca69a49eb7e39ed4cd7df3f6ed8bd1b68da6b1
+DIST mcstrans-3.3.tar.gz 44621 BLAKE2B 624780c219d0b8f369def5ab334caf9d2ae847f9cfb4359ce38e240bcb72b7cfeef45d08cd6e7330cc90394f6c32bd622d2133e675036f98992145b1530ab1e2 SHA512 2157a0361bb5a2bc8e149373b2dd7d9b042f8c4c0aa845ae6967a23d9b875d2dcd6176d99d7f8f15e17eb5877fea60814e19aabfe76950d25b75c9c25df811c2
diff --git a/sys-apps/mcstrans/mcstrans-3.3.ebuild b/sys-apps/mcstrans/mcstrans-3.3.ebuild
new file mode 100644
index 000000000000..631d654a0a38
--- /dev/null
+++ b/sys-apps/mcstrans/mcstrans-3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="SELinux context translation to human readable names"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/mcstransd.init" mcstransd
+}