summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-04-09 21:32:27 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-04-09 21:34:58 +0200
commitcd453e4d596fa10d27480ed5d19c97ae26496105 (patch)
treeb9d6517c63ab3fa550f49f6d9b9cf6552d0d5888 /sys-apps
parentapp-benchmarks/geekbench: add 6.0.2 (diff)
downloadgentoo-cd453e4d596fa10d27480ed5d19c97ae26496105.tar.gz
gentoo-cd453e4d596fa10d27480ed5d19c97ae26496105.tar.bz2
gentoo-cd453e4d596fa10d27480ed5d19c97ae26496105.zip
sys-apps/cpuid: add 20230406
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20230406.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index cff30c4c1c1b..e3e055752070 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1,2 +1,3 @@
DIST cpuid-20230120.src.tar.gz 141652 BLAKE2B 54843915be232762e35e6dfed3b7b582d192838bdc5e3b7ebb88b9ada217a3fd21d40faf248244047664f52c8e0c0689196b4373b01c2988aaa3738b7e69af3d SHA512 2b662c2db0ad013626245190be34aa3c04c01bb694111aafc4a491e0816fbb38d94e3d9b20770050efce0c08e6eaa9b22f6c8e9ea304d195afae17b6a4bbf2ab
DIST cpuid-20230306.src.tar.gz 144993 BLAKE2B 7d33e5e1e8fdfe60d555807be72ab3e0dc2d27445f5ab351c62c767cedf035ce49e4af19b3c7bbdf9e2ba460485ab8355d0491bf0d54b95cf7b2aabc512455fa SHA512 f62e458091ba630f835ddede7225421f9e8d5f4fa6c5c3ac363af0191e5740aacee4da2dfa90b1e35206659e1eabc8bd2cb94645c1347e98780e3a83fcdfc3b6
+DIST cpuid-20230406.src.tar.gz 147932 BLAKE2B 530d1d9207d6c2cb2bfe7006a445ac870edac77b35193042aa198a463aa3815b0eaf398f6831e7d6ae026256224b06b74d7682de6e6a7554d023cc32065b2beb SHA512 7b53e36c104fddb8a4c29d45d5fef80ad57fa2025e1daa116bb22aa184a3415c751affcf8b190aadd08af7cdca7801504b8ba84d87d14226318e0be72ee914d5
diff --git a/sys-apps/cpuid/cpuid-20230406.ebuild b/sys-apps/cpuid/cpuid-20230406.ebuild
new file mode 100644
index 000000000000..18c1efcd3afe
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20230406.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}