summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-26 19:18:43 +0100
committerSam James <sam@gentoo.org>2021-08-26 19:21:02 +0100
commit185c7bc43d6c85bfa46f3420493fbe3502071ad3 (patch)
treecd49ce66c63d0425359a88c5964dd207998b40a7 /sys-auth/nss_ldap/files
parentnet-analyzer/wireshark: add 3.4.8 (diff)
downloadgentoo-185c7bc43d6c85bfa46f3420493fbe3502071ad3.tar.gz
gentoo-185c7bc43d6c85bfa46f3420493fbe3502071ad3.tar.bz2
gentoo-185c7bc43d6c85bfa46f3420493fbe3502071ad3.zip
sys-auth/nss_ldap: fix finding glibc version on no-multilib
Bit of a hack but the rest of it is rather fragile anyway. The issue was that ${EPREFIX}/lib doesn't exist on non-multilib systems. Bug: https://bugs.gentoo.org/810058 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth/nss_ldap/files')
-rw-r--r--sys-auth/nss_ldap/files/nss_ldap-265-r10-libdir.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-auth/nss_ldap/files/nss_ldap-265-r10-libdir.patch b/sys-auth/nss_ldap/files/nss_ldap-265-r10-libdir.patch
new file mode 100644
index 000000000000..6fdf4cc6c08e
--- /dev/null
+++ b/sys-auth/nss_ldap/files/nss_ldap-265-r10-libdir.patch
@@ -0,0 +1,31 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -38,17 +38,13 @@
+ DEFS = @DEFS@
+ #INCLUDES = -I$(top_builddir) -I$(srcdir)
+
+-if GCC
+-MULTI_OS_DIRECTORY=$(shell $(CC) $(CFLAGS) -print-multi-os-directory)
+-else
+ MULTI_OS_DIRECTORY=.
+-endif
+
+ if GLIBC
+-LIBC_VERS = $(shell ls /lib/$(MULTI_OS_DIRECTORY)/libc-*.so | tail -n 1 | sed -e 's|.*libc-\(.*\)\.so|\1|')
++LIBC_VERS = $(shell ls @GENTOO_PORTAGE_EPREFIX@/$(LIBDIR_UNPREFIXED)/$(MULTI_OS_DIRECTORY)/libc-*.so | tail -n 1 | sed -e 's|.*libc-\(.*\)\.so|\1|')
+ NSS_LDAP_LIBC_VERSIONED = libnss_ldap-$(LIBC_VERS).so
+
+-NSS_VERS = $(shell ls /lib/$(MULTI_OS_DIRECTORY)/libnss_files.so.? | tail -n 1 | sed -e 's|.*libnss_files\.so\.\(.*\)|\1|')
++NSS_VERS = $(shell ls @GENTOO_PORTAGE_EPREFIX@/$(LIBDIR_UNPREFIXED)/$(MULTI_OS_DIRECTORY)/libnss_files.so.? | tail -n 1 | sed -e 's|.*libnss_files\.so\.\(.*\)|\1|')
+ NSS_LDAP_NSS_VERSIONED = libnss_ldap.so.$(NSS_VERS)
+ endif
+
+@@ -83,8 +79,6 @@
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
+ $(INSTALL_PROGRAM) -o $(INST_UID) -g $(INST_GID) nss_ldap.so $(DESTDIR)$(libdir)/$(NSS_LDAP_LIBC_VERSIONED)
+ (cd $(DESTDIR)$(libdir); ln -sf $(NSS_LDAP_LIBC_VERSIONED) $(NSS_LDAP_NSS_VERSIONED))
+- $(mkinstalldirs) $(DESTDIR)/usr$(libdir)
+- (cd $(DESTDIR)/usr$(libdir); ln -sf ../..$(libdir)/$(NSS_LDAP_NSS_VERSIONED) .)
+ else
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
+ if HPUX