summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-20 15:17:11 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-20 15:17:11 +0100
commit28b8b5944c4ffaaca1b2ac51d78fb83e80460002 (patch)
treea573caa7fb6a0d86f2898e1bbac38c66aa808dc5 /sys-auth
parentdev-libs/wayland: stable 1.19.0 for sparc, bug #774921 (diff)
downloadgentoo-28b8b5944c4ffaaca1b2ac51d78fb83e80460002.tar.gz
gentoo-28b8b5944c4ffaaca1b2ac51d78fb83e80460002.tar.bz2
gentoo-28b8b5944c4ffaaca1b2ac51d78fb83e80460002.zip
sys-auth/libyubikey: Port to EAPI 7
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/libyubikey/libyubikey-1.13.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/sys-auth/libyubikey/libyubikey-1.13.ebuild b/sys-auth/libyubikey/libyubikey-1.13.ebuild
index 77e3e6329d80..6fbe9d923189 100644
--- a/sys-auth/libyubikey/libyubikey-1.13.ebuild
+++ b/sys-auth/libyubikey/libyubikey-1.13.ebuild
@@ -1,18 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils autotools-utils
+EAPI=7
DESCRIPTION="Yubico C low-level library"
HOMEPAGE="https://github.com/Yubico/yubico-c"
-#http://opensource.yubico.com/yubico-c/releases.html
SRC_URI="http://opensource.yubico.com/yubico-c/releases/${P}.tar.gz"
-SLOT="0"
LICENSE="BSD-2"
+SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="static-libs"
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}