summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Depoire--Ferrer <greg.depoire@gmail.com>2021-08-04 12:37:52 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-08-07 04:24:50 -0400
commit9968e5f499f170ea40abe8996cb63f94e2e52a8c (patch)
tree20b27d6e94192ee1afe5252c672457773179df1b /sys-auth
parentwww-client/opera: remove old (diff)
downloadgentoo-9968e5f499f170ea40abe8996cb63f94e2e52a8c.tar.gz
gentoo-9968e5f499f170ea40abe8996cb63f94e2e52a8c.tar.bz2
gentoo-9968e5f499f170ea40abe8996cb63f94e2e52a8c.zip
sys-auth/seatd: Add builtin and server IUSE flags
The builtin flag is for enabling the embedded server backend in libseat that doesn't require starting a standalone server. It was disabled in the package previously but some users might want to enable it. The `server` flag is for enabling the standalone server. It was enabled in the package previously but some users might want to disable it. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Greg Depoire--Ferrer <greg.depoire@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21877 Acked-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/seatd/metadata.xml4
-rw-r--r--sys-auth/seatd/seatd-0.5.0-r1.ebuild53
-rw-r--r--sys-auth/seatd/seatd-9999.ebuild13
3 files changed, 66 insertions, 4 deletions
diff --git a/sys-auth/seatd/metadata.xml b/sys-auth/seatd/metadata.xml
index 260cfe0a1e16..dad3217f8ee8 100644
--- a/sys-auth/seatd/metadata.xml
+++ b/sys-auth/seatd/metadata.xml
@@ -9,4 +9,8 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+<use>
+ <flag name="builtin">Enable embedded server in libseat</flag>
+ <flag name="server">Enable standalone seatd server</flag>
+</use>
</pkgmetadata>
diff --git a/sys-auth/seatd/seatd-0.5.0-r1.ebuild b/sys-auth/seatd/seatd-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..ea510f9db2af
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.5.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson systemd
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="builtin elogind +server systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dwerror=false
+ $(meson_feature builtin)
+ $(meson_feature server)
+ )
+
+ if use elogind || use systemd; then
+ emesonargs+=( -Dlogind=enabled )
+ else
+ emesonargs+=( -Dlogind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use server; then
+ newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
+ fi
+}
diff --git a/sys-auth/seatd/seatd-9999.ebuild b/sys-auth/seatd/seatd-9999.ebuild
index ab311a6c5986..c826e115f27c 100644
--- a/sys-auth/seatd/seatd-9999.ebuild
+++ b/sys-auth/seatd/seatd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,7 @@ else
fi
LICENSE="MIT"
SLOT="0/1"
-IUSE="elogind systemd"
+IUSE="builtin elogind +server systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -30,6 +30,8 @@ src_configure() {
local emesonargs=(
-Dman-pages=enabled
-Dwerror=false
+ $(meson_feature builtin libseat-builtin)
+ $(meson_feature server)
)
if use elogind || use systemd; then
@@ -43,6 +45,9 @@ src_configure() {
src_install() {
meson_src_install
- newinitd "${FILESDIR}/seatd.initd" seatd
- systemd_dounit contrib/systemd/seatd.service
+
+ if use server; then
+ newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
+ fi
}