summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-09-09 16:10:45 +0200
committerHanno Böck <hanno@gentoo.org>2020-09-09 16:10:45 +0200
commitbd103ede269b873c62a22c6d22f5c4caa5c9052b (patch)
tree328ce96c56523d62662a7a69c627d5e01271de80 /sys-auth
parentnet-wireless/rtl-sdr: add a snapshot (diff)
downloadgentoo-bd103ede269b873c62a22c6d22f5c4caa5c9052b.tar.gz
gentoo-bd103ede269b873c62a22c6d22f5c4caa5c9052b.tar.bz2
gentoo-bd103ede269b873c62a22c6d22f5c4caa5c9052b.zip
sys-auth/pam_mount: Various fixes.
Remove old OpenSSL API. Support LibreSSL. Bump EAPI to 7. Remove unused empty dir causing QA warning. Signed-off-by: Hanno Böck <hanno@gentoo.org> Closes: https://bugs.gentoo.org/720244 Closes: https://bugs.gentoo.org/592584 Package-Manager: Portage-3.0.6, Repoman-3.0.1
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/files/pam_mount-2.16-remove-obsolete-openssl-api.patch17
-rw-r--r--sys-auth/pam_mount/pam_mount-2.16-r2.ebuild50
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-auth/pam_mount/files/pam_mount-2.16-remove-obsolete-openssl-api.patch b/sys-auth/pam_mount/files/pam_mount-2.16-remove-obsolete-openssl-api.patch
new file mode 100644
index 000000000000..6139ba6b648b
--- /dev/null
+++ b/sys-auth/pam_mount/files/pam_mount-2.16-remove-obsolete-openssl-api.patch
@@ -0,0 +1,17 @@
+These functions are obsolete and a noop in OpenSSL 1.1.
+
+diff -Naurp a/src/crypto.c b/src/crypto.c
+--- a/src/crypto.c 2016-09-23 09:52:47.000000000 +0200
++++ b/src/crypto.c 2020-09-09 11:20:44.291423666 +0200
+@@ -67,11 +67,6 @@ EXPORT_SYMBOL int cryptmount_init(void)
+ pthread_mutex_unlock(&ehd_init_lock);
+ return ret;
+ }
+-#ifdef HAVE_LIBCRYPTO
+- OpenSSL_add_all_algorithms();
+- OpenSSL_add_all_ciphers();
+- OpenSSL_add_all_digests();
+-#endif
+ }
+ ++ehd_use_count;
+ pthread_mutex_unlock(&ehd_init_lock);
diff --git a/sys-auth/pam_mount/pam_mount-2.16-r2.ebuild b/sys-auth/pam_mount/pam_mount-2.16-r2.ebuild
new file mode 100644
index 000000000000..6ba3bfb73868
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.16-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt libressl ssl selinux"
+
+COMMON_DEPEND=">=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1
+ >=dev-libs/libxml2-2.6
+ crypt? ( >=sys-fs/cryptsetup-1.1.0:= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/util-linux-2.20"
+
+PATCHES=(
+ "${FILESDIR}"/pam_mount-2.16-crypto-Add-support-for-LUKS2.patch
+ "${FILESDIR}"/pam_mount-2.16-remove-obsolete-openssl-api.patch
+)
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+
+ # Remove unused nonstandard run-dir, current version uses
+ # FHS-compatible /run, but has leftover mkdir from old version
+ rm -r "${D}/var/lib"
+}