summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-08-13 08:38:44 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-08-13 08:42:35 +0200
commit0bd11f8244d3c83037a41b92b317483c336d5167 (patch)
treefe61d69b2d007108506474129e309bed710df1c0 /sys-block/di/di-4.47.ebuild
parentsys-fs/cryptsetup: fix static pwquality build (diff)
downloadgentoo-0bd11f8244d3c83037a41b92b317483c336d5167.tar.gz
gentoo-0bd11f8244d3c83037a41b92b317483c336d5167.tar.bz2
gentoo-0bd11f8244d3c83037a41b92b317483c336d5167.zip
sys-block/di: Bump to version 4.47
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'sys-block/di/di-4.47.ebuild')
-rw-r--r--sys-block/di/di-4.47.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-block/di/di-4.47.ebuild b/sys-block/di/di-4.47.ebuild
new file mode 100644
index 000000000000..129c2ef259fc
--- /dev/null
+++ b/sys-block/di/di-4.47.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="http://www.gentoo.com/di/"
+SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RESTRICT="test" #405205, #405471
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.33-build.patch
+ "${FILESDIR}"/${PN}-4.47-no_echo-n.patch
+)
+
+src_configure() {
+ emake checkbuild
+ emake -C C config.h
+}
+
+src_compile() {
+ emake prefix=/usr CC="$(tc-getCC)" NLS=$(usex nls T F)
+}
+
+src_install() {
+ emake install prefix="${D}/usr"
+ # default symlink is broken
+ dosym di /usr/bin/mi
+ dodoc README
+}