summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-17 18:56:48 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-17 19:00:05 -0500
commit449cec71c892a45e0c43aa1019d5e08b6337d059 (patch)
tree6f7d7e86ac648b363f5512b76766588a9056035e /sys-block/open-iscsi
parentsys-block/open-iscsi: fix incorrect memset call (diff)
downloadgentoo-449cec71c892a45e0c43aa1019d5e08b6337d059.tar.gz
gentoo-449cec71c892a45e0c43aa1019d5e08b6337d059.tar.bz2
gentoo-449cec71c892a45e0c43aa1019d5e08b6337d059.zip
sys-block/open-iscsi: fix handling of user CPPFLAGS
Diffstat (limited to 'sys-block/open-iscsi')
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.873-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.873-r1.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.873-r1.ebuild
index 4392860d304d..05d979080711 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.873-r1.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.873-r1.ebuild
@@ -52,6 +52,8 @@ src_prepare() {
}
src_configure() {
+ use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
+
cd utils/open-isns || die
# SSL (--with-security) is broken
@@ -60,11 +62,11 @@ src_configure() {
}
src_compile() {
- use debug && append-flags -DDEBUG_TCP -DDEBUG_SCSI
-
+ # Stuffing CPPFLAGS into CFLAGS isn't entirely correct, but the build
+ # is messed up already here, so it's not making it that much worse.
KSRC="${KV_DIR}" CFLAGS="" \
emake \
- OPTFLAGS="${CFLAGS}" \
+ OPTFLAGS="${CFLAGS} ${CPPFLAGS}" \
AR="$(tc-getAR)" CC="$(tc-getCC)" \
user
}