summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Strypsteen <mathieu@strypsteen.me>2022-07-13 12:02:08 +0000
committerRick Farina <zerochaos@gentoo.org>2023-08-19 09:59:04 -0400
commitbb1244ed1a3397f9c53c913953673c74d876f03c (patch)
tree402ccfb5cf9d2f4c7c6273a85232e6c9023ca59f /sys-boot/mokutil
parentdev-ruby/did_you_mean: drop 1.5.0, 1.6.1, 1.6.2 (diff)
downloadgentoo-bb1244ed1a3397f9c53c913953673c74d876f03c.tar.gz
gentoo-bb1244ed1a3397f9c53c913953673c74d876f03c.tar.bz2
gentoo-bb1244ed1a3397f9c53c913953673c74d876f03c.zip
sys-boot/mokutil: add 0.6.0
Signed-off-by: Mathieu Strypsteen <mathieu@strypsteen.me> Signed-off-by: Rick Farina <zerochaos@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/26383
Diffstat (limited to 'sys-boot/mokutil')
-rw-r--r--sys-boot/mokutil/Manifest1
-rw-r--r--sys-boot/mokutil/mokutil-0.6.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/sys-boot/mokutil/Manifest b/sys-boot/mokutil/Manifest
index c1c7ed4b466f..7de58fb0b796 100644
--- a/sys-boot/mokutil/Manifest
+++ b/sys-boot/mokutil/Manifest
@@ -1,2 +1,3 @@
DIST mokutil-0.3.0_p20170405.tar.gz 32590 BLAKE2B 867574b05a7a7c842869f75bd3b6a0cd0af083862ffc912b25b12fe6283946968ac6872b25a727d37185fb821871d5a2f958afddbb7e2bfefde854c6f434ab8f SHA512 ee64627089efe341bff466249a126dcdcc4a53878b17f651b17423650c3aea76d52dcae01ed689ba5bd317125dd9a669816563aa676d46d8ac36863f38f9ea16
DIST mokutil-0.5.0.tar.gz 37181 BLAKE2B 6bd74e4ef2777afcd80cfe1d56dba7c861b9cb7bb957db19529dc36df7d6172c1d43870b80fbacd5f2bf20dbe9c8174be0d4cb5ce3638ce83a99795ae7627c4b SHA512 600c142fcc44e33efd307341b814018ef956668790b56d42a523140e81098746d14ae096fc6c93985b3c26bb414b8b6862f59312f2c4bd9d657a11e4becc6ea7
+DIST mokutil-0.6.0.tar.gz 38047 BLAKE2B f2307807c700091f1e5a783b3ad8e7b3eaa17e05580b2c24fd0e92433c6b9bedfb51e9eb2d5d1c71448623b12b6667a573dd51ed03fc738aaf9815083e118ca0 SHA512 11a9d172dba4fbb674e58e5d82cb1dc65a80cff844c0eaebd106b4d4608b24a8207e0cfabf36fe1eedb67f68a8a18db2136c7b62aa3230ac104615e8284dbd7d
diff --git a/sys-boot/mokutil/mokutil-0.6.0.ebuild b/sys-boot/mokutil/mokutil-0.6.0.ebuild
new file mode 100644
index 000000000000..cf7a65403d0e
--- /dev/null
+++ b/sys-boot/mokutil/mokutil-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="The utility to manipulate machines owner keys which managed in shim"
+HOMEPAGE="https://github.com/lcp/mokutil"
+SRC_URI="https://github.com/lcp/mokutil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/openssl:=
+ sys-apps/keyutils:=
+ sys-libs/efivar:=
+ virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}