summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <someone@example.com>2021-07-11 09:48:00 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-16 09:00:05 +0300
commit0790841c691104c135a1edf5f8c1c03051d39d5b (patch)
treebc55a08637176ad6af77d33ac3b516b137cc637b /sys-boot
parentdev-util/android-tools: New upstream, version bump (diff)
downloadgentoo-0790841c691104c135a1edf5f8c1c03051d39d5b.tar.gz
gentoo-0790841c691104c135a1edf5f8c1c03051d39d5b.tar.bz2
gentoo-0790841c691104c135a1edf5f8c1c03051d39d5b.zip
sys-boot/woeusb: bump to 5.1.2
This new version drops the GUI interface, so I will maintain both old version (v3) and new (v5+). Closes: https://bugs.gentoo.org/764491 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/woeusb/Manifest1
-rw-r--r--sys-boot/woeusb/woeusb-5.1.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-boot/woeusb/Manifest b/sys-boot/woeusb/Manifest
index 8bb853f6f1a5..df150530eef6 100644
--- a/sys-boot/woeusb/Manifest
+++ b/sys-boot/woeusb/Manifest
@@ -1 +1,2 @@
DIST woeusb-3.3.1.tar.gz 386399 BLAKE2B 1423ecca39018c674b0eea36de732f54cfcdd14b8cc465e6d3c0639192cbd8355436b7a39ba453b19fa6f1c5b1f6938ef12f49710bc2a4af0f2eaed967e03ce7 SHA512 e3460efabaee199eb5ffc73ca99fe2d9141ed3a5f72acd2f8910b093b2b3a93928ee4eeb27d634293448f036101d8bf24aef65dc338c80e6e3e1738004594d52
+DIST woeusb-5.1.2.tar.gz 160660 BLAKE2B 86fd0581ea2524d61ef48d9adf633d350ae214842ee8f26c2937f312fce864fa188fb40dd35e8e9b15c3eef46869f0099ee005e3c49fc219486d006357f74f09 SHA512 ee1341cdcaf203e4c5007e3ac19deb0b3bbee9e7eeb5ca9a74742d107b1b3e77e5b938d2f7de9ce23b7fba51d6a266ea26fb221300613c1c4c8d0cd4f8299f8b
diff --git a/sys-boot/woeusb/woeusb-5.1.2.ebuild b/sys-boot/woeusb/woeusb-5.1.2.ebuild
new file mode 100644
index 000000000000..77f857db0839
--- /dev/null
+++ b/sys-boot/woeusb/woeusb-5.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="https://github.com/WoeUSB/WoeUSB"
+SRC_URI="https://github.com/WoeUSB/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-SA-4.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # No test suite
+
+RDEPEND="
+ app-arch/wimlib
+ sys-apps/util-linux
+ sys-block/parted
+ sys-boot/grub:2[grub_platforms_pc]
+ sys-fs/dosfstools
+ sys-fs/ntfs3g
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/WoeUSB-${PV}"
+
+src_prepare() {
+ default
+ sed -i -e "s/@@WOEUSB_VERSION@@/${PV}/" sbin/"${PN}" || die
+}