summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-01-17 11:01:49 -0500
committerMike Gilbert <floppym@gentoo.org>2023-01-17 11:03:02 -0500
commit1087cf3bbb5bd0ae7fef283497aa19575a5e85e4 (patch)
treec213b31b9c17822fbd63d134b6db4491b06faa66 /sys-boot
parentsys-boot/grub: backport fix for MBR images with clang (diff)
downloadgentoo-1087cf3bbb5bd0ae7fef283497aa19575a5e85e4.tar.gz
gentoo-1087cf3bbb5bd0ae7fef283497aa19575a5e85e4.tar.bz2
gentoo-1087cf3bbb5bd0ae7fef283497aa19575a5e85e4.zip
sys-boot/grub: set GRUB_DISABLE_LINUX_PARTUUID=false by default
Closes: https://bugs.gentoo.org/711072 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/files/grub.default-476
-rw-r--r--sys-boot/grub/grub-2.06-r5.ebuild2
-rw-r--r--sys-boot/grub/grub-9999.ebuild2
3 files changed, 78 insertions, 2 deletions
diff --git a/sys-boot/grub/files/grub.default-4 b/sys-boot/grub/files/grub.default-4
new file mode 100644
index 000000000000..35d3060137a9
--- /dev/null
+++ b/sys-boot/grub/files/grub.default-4
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+#
+# To populate all changes in this file you need to regenerate your
+# grub configuration file afterwards:
+# 'grub-mkconfig -o /boot/grub/grub.cfg'
+#
+# See the grub info page for documentation on possible variables and
+# their associated values.
+
+GRUB_DISTRIBUTOR="Gentoo"
+
+# Default menu entry
+#GRUB_DEFAULT=0
+
+# Boot the default entry this many seconds after the menu is displayed
+#GRUB_TIMEOUT=5
+#GRUB_TIMEOUT_STYLE=menu
+
+# Append parameters to the linux kernel command line
+#GRUB_CMDLINE_LINUX=""
+#
+# Examples:
+#
+# Boot with network interface renaming disabled
+# GRUB_CMDLINE_LINUX="net.ifnames=0"
+#
+# Boot with systemd instead of sysvinit (openrc)
+# GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"
+
+# Append parameters to the linux kernel command line for non-recovery entries
+#GRUB_CMDLINE_LINUX_DEFAULT=""
+
+# Uncomment to disable graphical terminal (grub-pc only)
+#GRUB_TERMINAL=console
+
+# The resolution used on graphical terminal.
+# Note that you can use only modes which your graphic card supports via VBE.
+# You can see them in real GRUB with the command `vbeinfo'.
+#GRUB_GFXMODE=640x480
+
+# Set to 'text' to force the Linux kernel to boot in normal text
+# mode, 'keep' to preserve the graphics mode set using
+# 'GRUB_GFXMODE', 'WIDTHxHEIGHT'['xDEPTH'] to set a particular
+# graphics mode, or a sequence of these separated by commas or
+# semicolons to try several modes in sequence.
+#GRUB_GFXPAYLOAD_LINUX=
+
+# Path to theme spec txt file.
+# The starfield is by default provided with use truetype.
+# NOTE: when enabling custom theme, ensure you have required font/etc.
+#GRUB_THEME="/boot/grub/themes/starfield/theme.txt"
+
+# Background image used on graphical terminal.
+# Can be in various bitmap formats.
+#GRUB_BACKGROUND="/boot/grub/mybackground.png"
+
+# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to kernel
+#GRUB_DISABLE_LINUX_UUID=true
+
+# Comment if you don't want GRUB to pass "root=PARTUUID=xxx" parameter to kernel
+GRUB_DISABLE_LINUX_PARTUUID=false
+
+# Uncomment to disable generation of recovery mode menu entries
+#GRUB_DISABLE_RECOVERY=true
+
+# Uncomment to disable generation of the submenu and put all choices on
+# the top-level menu.
+# Besides the visual affect of no sub menu, this makes navigation of the
+# menu easier for a user who can't see the screen.
+#GRUB_DISABLE_SUBMENU=y
+
+# Uncomment to play a tone when the main menu is displayed.
+# This is useful, for example, to allow users who can't see the screen
+# to know when they can make a choice on the menu.
+#GRUB_INIT_TUNE="60 800 1"
diff --git a/sys-boot/grub/grub-2.06-r5.ebuild b/sys-boot/grub/grub-2.06-r5.ebuild
index 7267ddc5002b..06b35f228a26 100644
--- a/sys-boot/grub/grub-2.06-r5.ebuild
+++ b/sys-boot/grub/grub-2.06-r5.ebuild
@@ -297,7 +297,7 @@ src_install() {
einstalldocs
insinto /etc/default
- newins "${FILESDIR}"/grub.default-3 grub
+ newins "${FILESDIR}"/grub.default-4 grub
# https://bugs.gentoo.org/231935
dostrip -x /usr/lib/grub
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index cc531c4c9010..359da219ea62 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -290,7 +290,7 @@ src_install() {
einstalldocs
insinto /etc/default
- newins "${FILESDIR}"/grub.default-3 grub
+ newins "${FILESDIR}"/grub.default-4 grub
# https://bugs.gentoo.org/231935
dostrip -x /usr/lib/grub