summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-12 13:45:59 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-12 13:46:44 -0700
commit0fb3b4acc70849deeee7a7cf07bc111e34be12fc (patch)
tree15ea07536a4d291c49db96e67c5a36bfc1d36813 /sys-cluster/ceph
parentdev-embedded/openocd: Add calls to udev_reload (diff)
downloadgentoo-0fb3b4acc70849deeee7a7cf07bc111e34be12fc.tar.gz
gentoo-0fb3b4acc70849deeee7a7cf07bc111e34be12fc.tar.bz2
gentoo-0fb3b4acc70849deeee7a7cf07bc111e34be12fc.zip
sys-cluster/ceph: Add patch to attempt to fix bug #854681
I am unable to reproduce this bug, but this patch should theoretically fix it. Please reopen the bug if the issue still exists. Closes: https://bugs.gentoo.org/854681 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ceph-17.2.3.ebuild1
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-17.2.3.ebuild b/sys-cluster/ceph/ceph-17.2.3.ebuild
index 8a67048c3455..49a8857b5c24 100644
--- a/sys-cluster/ceph/ceph-17.2.3.ebuild
+++ b/sys-cluster/ceph/ceph-17.2.3.ebuild
@@ -216,6 +216,7 @@ PATCHES=(
"${FILESDIR}/ceph-17.2.0-fuse3.patch"
"${FILESDIR}/ceph-17.2.0-osd_class_dir.patch"
"${FILESDIR}/ceph-17.2.1-python310.patch"
+ "${FILESDIR}/ceph-17.2.3-gcc12.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch b/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch
new file mode 100644
index 000000000000..e5e77b4116f6
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.3-gcc12.patch
@@ -0,0 +1,12 @@
+diff --git a/src/include/buffer.h b/src/include/buffer.h
+index 0c89367dd3b..98fcd7c3e08 100644
+--- a/src/include/buffer.h
++++ b/src/include/buffer.h
+@@ -62,6 +62,7 @@
+ #endif
+
+ #include "inline_memory.h"
++#include <memory>
+
+ #define CEPH_BUFFER_API
+