summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-09-11 17:43:15 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-09-11 18:24:13 -0700
commit53d0cf3fea7329105087366c750a496257af3930 (patch)
treeab0fceaea84f375254bb0ba080f490514770c1b6 /sys-cluster/ceph
parentmedia-video/pipewire: handle procps-4 rename of pwait->pidwait (diff)
downloadgentoo-53d0cf3fea7329105087366c750a496257af3930.tar.gz
gentoo-53d0cf3fea7329105087366c750a496257af3930.tar.bz2
gentoo-53d0cf3fea7329105087366c750a496257af3930.zip
sys-cluster/ceph: Revbump, update cython dep to force <3, install cephadm
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ceph-17.2.6-r7.ebuild (renamed from sys-cluster/ceph/ceph-17.2.6-r6.ebuild)6
-rw-r--r--sys-cluster/ceph/ceph-18.2.0-r1.ebuild (renamed from sys-cluster/ceph/ceph-18.2.0.ebuild)4
2 files changed, 8 insertions, 2 deletions
diff --git a/sys-cluster/ceph/ceph-17.2.6-r6.ebuild b/sys-cluster/ceph/ceph-17.2.6-r7.ebuild
index 2d7cf423fb87..2b0df75bacb3 100644
--- a/sys-cluster/ceph/ceph-17.2.6-r6.ebuild
+++ b/sys-cluster/ceph/ceph-17.2.6-r7.ebuild
@@ -109,7 +109,7 @@ BDEPEND="
x86? ( dev-lang/yasm )
app-arch/cpio
>=dev-util/cmake-3.5.0
- dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/cython-3[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx
dev-util/gperf
@@ -468,6 +468,10 @@ src_install() {
python_install() {
local CMAKE_USE_DIR="${S}"
DESTDIR="${ED}" cmake_build src/pybind/install
+ DESTDIR="${ED}" cmake_build src/cephadm/install
+
+ python_scriptinto /usr/sbin
+ python_doscript src/cephadm/cephadm
python_optimize
}
diff --git a/sys-cluster/ceph/ceph-18.2.0.ebuild b/sys-cluster/ceph/ceph-18.2.0-r1.ebuild
index ca91f209f974..d77b75bd63ff 100644
--- a/sys-cluster/ceph/ceph-18.2.0.ebuild
+++ b/sys-cluster/ceph/ceph-18.2.0-r1.ebuild
@@ -112,7 +112,7 @@ BDEPEND="
x86? ( dev-lang/yasm )
app-arch/cpio
>=dev-util/cmake-3.5.0
- dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/cython-3[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx
dev-util/gperf
@@ -403,6 +403,7 @@ python_compile() {
ceph_src_configure
cmake_build src/pybind/CMakeFiles/cython_modules
+ cmake_build cephadm
}
src_install() {
@@ -466,6 +467,7 @@ src_install() {
python_install() {
local CMAKE_USE_DIR="${S}"
DESTDIR="${ED}" cmake_build src/pybind/install
+ DESTDIR="${ED}" cmake_build src/cephadm/install
python_optimize
}