summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-07-12 15:47:18 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-07-12 17:19:48 -0700
commita4be3d5347668f59ece000c45cbb019f793c716f (patch)
tree0231a5b4c43a259b73b684fd7a72e617ce606270 /sys-cluster/ceph
parentmedia-fonts/encodings: Version bump to 1.0.6 (diff)
downloadgentoo-a4be3d5347668f59ece000c45cbb019f793c716f.tar.gz
gentoo-a4be3d5347668f59ece000c45cbb019f793c716f.tar.bz2
gentoo-a4be3d5347668f59ece000c45cbb019f793c716f.zip
sys-cluster/ceph: Revbump to 16.2.9-r1 fix #857702
Also change libfmt dep to be <9.0 Bug: https://bugs.gentoo.org/857702 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/Manifest2
-rw-r--r--sys-cluster/ceph/ceph-16.2.9-r1.ebuild (renamed from sys-cluster/ceph/ceph-16.2.9.ebuild)3
-rw-r--r--sys-cluster/ceph/files/ceph-16.2.9-python310.patch12
3 files changed, 14 insertions, 3 deletions
diff --git a/sys-cluster/ceph/Manifest b/sys-cluster/ceph/Manifest
index d2eb006a495d..9b6f58453e84 100644
--- a/sys-cluster/ceph/Manifest
+++ b/sys-cluster/ceph/Manifest
@@ -1,4 +1,2 @@
DIST ceph-15.2.16.tar.gz 148628915 BLAKE2B 4f624078027c706428eae3eddd5b5479efe3b4442c19a4e6b6cdf8d3839cf56e2863b18249dc3c5079a7e25f60796bfec3202ffd695537587654f5e2f820caaa SHA512 532b8a5073e157fe9ed552b26976faeb64dc29b79a249910c0982134ad5f945d4f57d8bf451adf63487b6d285c6e4bd5c39f0e3fcd449230d6fb3087539f8c3b
DIST ceph-16.2.9.tar.gz 157168096 BLAKE2B 0a667a9699925cfc920ca0cc535e5331cbcd95997fb0b9816a4d84c8add454b6b17813018bc1d1de07c802167ef50aa528704b10b01f42759189392ccdb5088f SHA512 bf369038ad6383f88abbed267f0239e9d8a1d33b46b34ed260aeeb1fda1b374cb6e658238e1ace013fbbb68e73b8cd2922b7def318d7a110e5f4560eeae8fca3
-DIST ceph-17.2.1.tar.gz 168819036 BLAKE2B 2d6506f3a43ccbe4a149163c13ab2de72aeba568308ca7c0c59d0ff32316519d27b334451fd8d78af799cabe3b5a8c5b7b19d5da028e52c420ec7fc38efe5aad SHA512 cb88a3feff67ce41c575cb6c0067a32de51fcbf36d8f9f7273cccd54a3413ee890f473e83fcc1429a86b858b05c412fca8b2cfc24871c5adf612e3d224227cf0
-DIST ceph-xsimd-17.2.1.tar.gz 173025 BLAKE2B 54679c24804c195ae55b9f49589e331dde92c6d89aaa20e827539e9a4e0010c7549cdd5cf02a7ebed83f953ab2a6f1d9cc9a98cf45c3dc7758ae4938c9c43713 SHA512 ecc58e7909648aaa22aefbf76ee2c5a2bece4b1b88da9c7eda1b69a46247e619ff99c4366afd6015f95debd68c1a6b89292c677b9049462d0fc0255fbc0c2a33
diff --git a/sys-cluster/ceph/ceph-16.2.9.ebuild b/sys-cluster/ceph/ceph-16.2.9-r1.ebuild
index 688c98bb2b8f..880937c7a706 100644
--- a/sys-cluster/ceph/ceph-16.2.9.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.9-r1.ebuild
@@ -48,7 +48,7 @@ DEPEND="
dev-cpp/gflags:=
<dev-libs/leveldb-1.23:=[snappy,tcmalloc(-)?]
dev-libs/libaio:=
- dev-libs/libfmt:=
+ <dev-libs/libfmt-9:=
dev-libs/libnl:3=
dev-libs/libxml2:=
dev-libs/libevent:=
@@ -217,6 +217,7 @@ PATCHES=(
"${FILESDIR}/ceph-16.2.2-system-zstd.patch"
"${FILESDIR}/ceph-16.2.7-string-includes.patch"
"${FILESDIR}/ceph-17.2.0-fuse3.patch"
+ "${FILESDIR}/ceph-16.2.9-python310.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/files/ceph-16.2.9-python310.patch b/sys-cluster/ceph/files/ceph-16.2.9-python310.patch
new file mode 100644
index 000000000000..403cfe2f3d1d
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-16.2.9-python310.patch
@@ -0,0 +1,12 @@
+diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
+index 38aad299ccb..8e152e060ea 100644
+--- a/src/mgr/CMakeLists.txt
++++ b/src/mgr/CMakeLists.txt
+@@ -34,6 +34,7 @@ if(WITH_MGR)
+ mgr_commands.cc
+ $<TARGET_OBJECTS:mgr_cap_obj>)
+ add_executable(ceph-mgr ${mgr_srcs})
++ target_compile_definitions(ceph-mgr PRIVATE PY_SSIZE_T_CLEAN)
+ target_link_libraries(ceph-mgr
+ osdc client heap_profiler
+ global-static ceph-common