summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-03-18 10:41:01 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-03-18 10:49:54 -0500
commit1cc5dcfe67ee85e281c31b1c1b1e8f9c345f3129 (patch)
treeebd524b96d5b2a298ee5fbebaa6f0c691e7fe469 /sys-cluster/kube-proxy/kube-proxy-1.27.12.ebuild
parentsys-cluster/kubelet: add 1.27.12 (diff)
downloadgentoo-1cc5dcfe67ee85e281c31b1c1b1e8f9c345f3129.tar.gz
gentoo-1cc5dcfe67ee85e281c31b1c1b1e8f9c345f3129.tar.bz2
gentoo-1cc5dcfe67ee85e281c31b1c1b1e8f9c345f3129.zip
sys-cluster/kube-proxy: add 1.27.12
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.27.12.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.27.12.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.27.12.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.27.12.ebuild
new file mode 100644
index 000000000000..19efcef72cdb
--- /dev/null
+++ b/sys-cluster/kube-proxy/kube-proxy-1.27.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Kubernetes Proxy service"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="hardened"
+
+RDEPEND="net-firewall/conntrack-tools"
+BDEPEND=">=dev-lang/go-1.20"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" FORCE_HOST_GO=yes \
+ emake -j1 GOFLAGS="" GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ keepdir /var/log/${PN} /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}