summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-10-16 12:08:54 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-10-16 12:08:54 +0200
commite4ef5120d3ad2956cc43af075c6c0900b9937e5a (patch)
tree4d8b729dc98c6d9213f84b29f06114f305758fcb /sys-cluster/kubeadm/kubeadm-1.14.8.ebuild
parentsys-cluster/kube-proxy: Remove old (diff)
downloadgentoo-e4ef5120d3ad2956cc43af075c6c0900b9937e5a.tar.gz
gentoo-e4ef5120d3ad2956cc43af075c6c0900b9937e5a.tar.bz2
gentoo-e4ef5120d3ad2956cc43af075c6c0900b9937e5a.zip
sys-cluster/kubeadm: Version bump to 1.14.8
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'sys-cluster/kubeadm/kubeadm-1.14.8.ebuild')
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.14.8.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-cluster/kubeadm/kubeadm-1.14.8.ebuild b/sys-cluster/kubeadm/kubeadm-1.14.8.ebuild
new file mode 100644
index 000000000000..763c3838067b
--- /dev/null
+++ b/sys-cluster/kubeadm/kubeadm-1.14.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot bash-completion-r1
+
+EGO_PN="k8s.io/kubernetes"
+ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.12
+ dev-go/go-bindata"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
+ pushd src/${EGO_PN} || die
+ eapply "${FILESDIR}/${PN}-1.14-openrc.patch"
+ popd || die
+}
+
+src_compile() {
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
+ pushd src/${EGO_PN} || die
+ _output/bin/${PN} completion bash > ${PN}.bash || die
+ _output/bin/${PN} completion zsh > ${PN}.zsh || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin _output/bin/${PN}
+
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ popd || die
+}