summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-12-12 07:45:14 +0100
committerUlrich Müller <ulm@gentoo.org>2022-01-01 11:48:02 +0100
commitbb74aef6ad00a1e26ccc5d8d10328dd5bf1ae3f7 (patch)
treed17d74ec1cd47515f38bd14f287431644751a0a4 /sys-cluster/pacemaker
parentsys-cluster/galera: revbump galera-26.4.10 to r1 (diff)
downloadgentoo-bb74aef6ad00a1e26ccc5d8d10328dd5bf1ae3f7.tar.gz
gentoo-bb74aef6ad00a1e26ccc5d8d10328dd5bf1ae3f7.tar.bz2
gentoo-bb74aef6ad00a1e26ccc5d8d10328dd5bf1ae3f7.zip
sys-cluster/pacemaker: bump to 2.1.2 and EAPI 8
Package-Manager: Portage-3.0.29, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/Manifest1
-rw-r--r--sys-cluster/pacemaker/pacemaker-2.1.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sys-cluster/pacemaker/Manifest b/sys-cluster/pacemaker/Manifest
index f786c4c0da80..f102e5a0dd85 100644
--- a/sys-cluster/pacemaker/Manifest
+++ b/sys-cluster/pacemaker/Manifest
@@ -1 +1,2 @@
DIST Pacemaker-2.0.5.tar.gz 5434850 BLAKE2B 4e3d24746978fe0785dd9c415cc3779a2bd06f78d8bcd3353cdab8c93b192db8a017d404f6d5e27852369e8db2dc1ee4a2c4c7806ebb1aad5381d1c5b5a681dc SHA512 5fd3614f0284297babb66ea2dc567583315052fcf77f49107c52161e8e8c164ae3169d98528fdc1316d8eabaacc98ed24e9c6e6c90b3286f2f012a4ee874bbba
+DIST Pacemaker-2.1.2.tar.gz 5092063 BLAKE2B 04689762cd3767fec35fc577b79007e7004411d4bb8676a0410c75619c35d1f158811555ea7d156accbb3e75a427128ab735ca21ad177934634b27fe2837175f SHA512 5c30ac5c371bb1f37215a9cf3e2eec701f7e4133252401dd2793b0908f2192de1d0b625cc37d84dfc9fd0885039c4d88e617110135c5e1a16c40cd3218603c26
diff --git a/sys-cluster/pacemaker/pacemaker-2.1.2.ebuild b/sys-cluster/pacemaker/pacemaker-2.1.2.ebuild
new file mode 100644
index 000000000000..cce5b69b1d0a
--- /dev/null
+++ b/sys-cluster/pacemaker/pacemaker-2.1.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-single-r1
+
+MY_P="${PN^}-${PV/_/-}"
+
+DESCRIPTION="Pacemaker CRM"
+HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
+SRC_URI="https://github.com/ClusterLabs/${PN}/archive/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="acl smtp snmp"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=sys-cluster/cluster-glue-1.0.12-r1
+ >=sys-cluster/libqb-2.0.0:=
+ sys-cluster/resource-agents
+ sys-cluster/corosync
+ smtp? ( net-libs/libesmtp )
+ snmp? ( net-analyzer/net-snmp )
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ -ggdb//g" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ local myconf=(
+ --with-ocfdir=/usr/$(get_libdir)/ocf
+ --localstatedir=/var
+ --disable-fatal-warnings
+ --disable-static
+ --without-cs-quorum
+ --without-cman
+ --without-heartbeat
+ --with-corosync
+ --with-ais
+ $(use_with acl)
+ $(use_with smtp esmtp)
+ $(use_with snmp)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ # remove provided initd file as we need support for OpenRC
+ rm -r "${ED}/var/run" "${ED}/etc/init.d" || die "Failed to remove old initd"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+
+ keepdir /var/lib/pacemaker/{blackbox,cib,cores,pengine}
+ keepdir /var/log/pacemaker/bundles
+
+ find "${ED}" -name '*.la' -delete || die
+}