summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-devel/bmake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-devel/bmake')
-rw-r--r--sys-devel/bmake/Manifest2
-rw-r--r--sys-devel/bmake/bmake-20140214.ebuild55
-rw-r--r--sys-devel/bmake/metadata.xml5
3 files changed, 62 insertions, 0 deletions
diff --git a/sys-devel/bmake/Manifest b/sys-devel/bmake/Manifest
new file mode 100644
index 000000000000..39b0f121dd61
--- /dev/null
+++ b/sys-devel/bmake/Manifest
@@ -0,0 +1,2 @@
+DIST bmake-20140214.tar.gz 508662 SHA256 2ec1771a800431c26361659ab0f96ec5c2536e85b46564eb69fa75a4b12886de SHA512 760d90652bdab5ac595a96974fd99147e5edb4cf0ab7bad477d77ad63184a3b487f253648b53767cf1d3eccfa5c57dd3dfc2b3256578231b646c4f409cc5d758 WHIRLPOOL c29f40f44f9447a2ce274d24ef9403bb42b616424c72194af96cba360eae73fa5ad89ff045f425e063419c8fd517c2dd463ca70fc8e2b0bb5864c4307a255db2
+DIST mk-20121010.tar.gz 71484 SHA256 7bf6cb980d077f725893b7b526f27b325f202fde04b8b4152e125e29f819d655 SHA512 57dab8846261b6ae84bc2f7ced2c05cb60b82b59d7983c7a318c2b5c173f0a0b2bf6289eefd0f5697a0d0a7095e3ae5ff3f07af32bce21be6d7068e7938f02f8 WHIRLPOOL 830158af62fd96ee02a3fba4f2402fb4e9f6cefa6f3bc2df624781fc7e3545b049780d1176280c073531f9e1e5c32db5ac6c6db9105f33b26d254dbb062c041e
diff --git a/sys-devel/bmake/bmake-20140214.ebuild b/sys-devel/bmake/bmake-20140214.ebuild
new file mode 100644
index 000000000000..2bd01f3bca61
--- /dev/null
+++ b/sys-devel/bmake/bmake-20140214.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils
+
+MK_VER=20121010
+DESCRIPTION="NetBSD's portable make"
+HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
+SRC_URI="http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
+ http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x64-freebsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ econf \
+ --with-mksrc=../mk \
+ --with-default-sys-path="${EPREFIX}"/usr/share/mk/${PN} \
+ --with-machine_arch=${ARCH}
+}
+
+src_compile() {
+ sh make-bootstrap.sh || die "bootstrap failed"
+}
+
+src_test() {
+ cd unit-tests
+ LC_ALL=C env -u A ${S}/bmake -r -m . > test.out 2>&1 \
+ || die "tests compilation failed"
+ sed -i \
+ -e "s:${S}/::g" \
+ -e "s:bmake\\[.\\]:make:g" \
+ -e "s:unit-tests/::g" \
+ test.out || die "Fixing values failed"
+ diff -u test.exp test.out
+ [[ $(diff -u test.exp test.out |wc -l) -gt 0 ]] && die "tests differ"
+}
+
+src_install() {
+ dobin ${PN} || die
+ newman ${PN}.cat1 ${PN}.1 || die
+ FORCE_BSD_MK=1 SYS_MK_DIR=. \
+ sh ../mk/install-mk -v -m 644 "${ED}"/usr/share/mk/${PN} \
+ || die "failed to install mk files"
+}
diff --git a/sys-devel/bmake/metadata.xml b/sys-devel/bmake/metadata.xml
new file mode 100644
index 000000000000..ecedda4aa2cc
--- /dev/null
+++ b/sys-devel/bmake/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>bsd</herd>
+</pkgmetadata>