summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-17 00:17:29 +0100
committerSam James <sam@gentoo.org>2023-05-17 00:17:29 +0100
commit3d3dbcb7be81dae3816aff400f7461beba4ddb22 (patch)
tree899dbdb7aa0d80bcf3a3803575f8843ef4bd4e9a /sys-devel/clang-common
parentsys-devel/clang-common: add maybe-stddefs.h helper (diff)
downloadgentoo-3d3dbcb7be81dae3816aff400f7461beba4ddb22.tar.gz
gentoo-3d3dbcb7be81dae3816aff400f7461beba4ddb22.tar.bz2
gentoo-3d3dbcb7be81dae3816aff400f7461beba4ddb22.zip
sys-devel/clang-common: add __GLIBC__ guard to maybe-stddefs.h too
It should be fine without this, but we know glibc has a safeguard to make sure it's included, so let's not interfere there. Bug: https://bugs.gentoo.org/870001 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-16.0.3-r1.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.4.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-16.0.3-r1.ebuild b/sys-devel/clang-common/clang-common-16.0.3-r1.ebuild
index 0d894d8b4232..358dca01c333 100644
--- a/sys-devel/clang-common/clang-common-16.0.3-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.3-r1.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF
diff --git a/sys-devel/clang-common/clang-common-16.0.4.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.4.9999.ebuild
index ffae670e7202..51e0f70c6470 100644
--- a/sys-devel/clang-common/clang-common-16.0.4.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.4.9999.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index ffae670e7202..51e0f70c6470 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF
diff --git a/sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild b/sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild
index ffae670e7202..51e0f70c6470 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_pre20230502.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF
diff --git a/sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild b/sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild
index ffae670e7202..51e0f70c6470 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_pre20230512.ebuild
@@ -106,7 +106,7 @@ src_install() {
cat >> "${ED}/usr/include/gentoo/maybe-stddefs.h" <<-EOF || die
/* __has_include is an extension, but it's fine, because this is only
for Clang anyway. */
- #if defined __has_include && __has_include (<stdc-predef.h>)
+ #if defined __has_include && __has_include (<stdc-predef.h>) && !defined(__GLIBC__)
# include <stdc-predef.h>
#endif
EOF