summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-26 09:21:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-26 10:42:55 +0200
commit000c4a80f0932c2e27ea2192d53b04740da08ea9 (patch)
tree412c90565878a2d42b3854d64d48c8354866ddf1 /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 15.0.0_rc3 (diff)
downloadgentoo-000c4a80f0932c2e27ea2192d53b04740da08ea9.tar.gz
gentoo-000c4a80f0932c2e27ea2192d53b04740da08ea9.tar.bz2
gentoo-000c4a80f0932c2e27ea2192d53b04740da08ea9.zip
sys-devel/clang-runtime: Bump to 15.0.0_rc3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.0_rc3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.0_rc3.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.0_rc3.ebuild
new file mode 100644
index 000000000000..e4ff9326ddcb
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.0_rc3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"