summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-01-07 16:25:38 +0100
committerMichał Górny <mgorny@gentoo.org>2016-01-07 23:09:41 +0100
commit228b9cfe60081550ad12b8079a0caa1e2f762f8f (patch)
tree4d4f3aeab4a74e4aca7f2ab35eb4069b9919bb93 /sys-devel/clang
parentwww-plugins/lightspark: Remove old vers requiring llvm-3.2 (diff)
downloadgentoo-228b9cfe60081550ad12b8079a0caa1e2f762f8f.tar.gz
gentoo-228b9cfe60081550ad12b8079a0caa1e2f762f8f.tar.bz2
gentoo-228b9cfe60081550ad12b8079a0caa1e2f762f8f.zip
sys-devel/clang: Remove ancient 3.2 version
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/Manifest3
-rw-r--r--sys-devel/clang/clang-3.2.ebuild202
-rw-r--r--sys-devel/clang/files/clang-2.7-fixdoc.patch53
-rw-r--r--sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch188
-rw-r--r--sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch20
-rw-r--r--sys-devel/clang/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch29
6 files changed, 0 insertions, 495 deletions
diff --git a/sys-devel/clang/Manifest b/sys-devel/clang/Manifest
deleted file mode 100644
index f77149fc13c7..000000000000
--- a/sys-devel/clang/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST clang-3.2.src.tar.gz 8805311 SHA256 2aaaf03f7c0f6b16fe97ecc81247dc2bf2d4bec7620a77cc74670b7e07ff5658 SHA512 99fc57d19b76c42af9821eaaa762056a926eb68178f6b7dd5e8bf092c9ee201a554b91d760d5a30a57f38102eae340e080ef8c6a39327f6881eda391b20b108d WHIRLPOOL 2cf88d1db0f108d8b8e8b0cf691cca18694ddb00b129dc8c1894fca67b5494a7f53f92ac9401d99ce687c9d8fb30dc267be1e68ee70edc542e998f5486ba8730
-DIST compiler-rt-3.2.src.tar.gz 1463061 SHA256 4ac311df0eead459cbb0f0890c06b55dae529ab45827ac73fef40bec632994aa SHA512 ef4223bd2d6051ec93a0943973aa61e7aa3686ac72f9a688d58a8b71deba1a7e64dcf821e0c53937899bbd7ba49218fee4e3649f19362fe59677daee314c063b WHIRLPOOL 176643360f683ddca28e4c77dc4ceb03513cec5cea98455598c934ec3e23bd6949a74852e50e42207c7171eb8013afe366f3b8c92799af66a04739ccebe4ed4e
-DIST llvm-3.2.src.tar.gz 12275252 SHA256 125090c4d26740f1d5e9838477c931ed7d9ad70d599ba265f46f3a42cb066343 SHA512 cc66171322dbbe40bcac0e0ea5b09df8ff52df63ded304f841f32f702270d6ab1512216413ee52498c3ebee8cd39c4cd23e3855d591944bc2ac0ae76f5be62cc WHIRLPOOL c3a39b2426293d0251b7769607ade873bb6bf8d54e7c8055773a9b75742bc8e39049fb71409a258c6f3d98775b78c280d4bfe4223ba91e5ed6ecae0eddf910e5
diff --git a/sys-devel/clang/clang-3.2.ebuild b/sys-devel/clang/clang-3.2.ebuild
deleted file mode 100644
index f0688050fc1a..000000000000
--- a/sys-devel/clang/clang-3.2.ebuild
+++ /dev/null
@@ -1,202 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit eutils multilib python-r1
-
-DESCRIPTION="C language family frontend for LLVM"
-HOMEPAGE="http://clang.llvm.org/"
-# Fetching LLVM as well: see http://llvm.org/bugs/show_bug.cgi?id=4840
-SRC_URI="http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.gz
- http://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.gz
- http://llvm.org/releases/${PV}/${P}.src.tar.gz"
-
-LICENSE="UoI-NCSA"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="debug kernel_FreeBSD multitarget python +static-analyzer test"
-
-DEPEND="static-analyzer? ( dev-lang/perl )
- ${PYTHON_DEPS}"
-RDEPEND="~sys-devel/llvm-${PV}[debug=,multitarget=]
- ${PYTHON_DEPS}"
-
-S=${WORKDIR}/llvm-${PV}.src
-
-src_prepare() {
- rm -f "${S}"/tools/clang "${S}"/projects/compiler-rt \
- || die "symlinks removal failed"
- mv "${WORKDIR}"/${P}.src "${S}"/tools/clang \
- || die "clang source directory move failed"
- mv "${WORKDIR}"/compiler-rt-${PV}.src "${S}"/projects/compiler-rt \
- || die "compiler-rt source directory move failed"
-
- # Same as llvm doc patches
- epatch "${FILESDIR}"/${PN}-2.7-fixdoc.patch
-
- # multilib-strict
- sed -e "/PROJ_headers/s#lib/clang#$(get_libdir)/clang#" \
- -i tools/clang/lib/Headers/Makefile \
- || die "clang Makefile failed"
- sed -e "/PROJ_resources/s#lib/clang#$(get_libdir)/clang#" \
- -i tools/clang/runtime/compiler-rt/Makefile \
- || die "compiler-rt Makefile failed"
- # fix the static analyzer for in-tree install
- sed -e 's/import ScanView/from clang \0/' \
- -i tools/clang/tools/scan-view/scan-view \
- || die "scan-view sed failed"
- sed -e "/scanview.css\|sorttable.js/s#\$RealBin#${EPREFIX}/usr/share/${PN}#" \
- -i tools/clang/tools/scan-build/scan-build \
- || die "scan-build sed failed"
- # Set correct path for gold plugin
- sed -e "/LLVMgold.so/s#lib/#$(get_libdir)/llvm/#" \
- -i tools/clang/lib/Driver/Tools.cpp \
- || die "gold plugin path sed failed"
-
- # From llvm src_prepare
- einfo "Fixing install dirs"
- sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(PROJ_prefix)/share/doc/'${PF}, \
- -e 's,^PROJ_etcdir.*,PROJ_etcdir := '"${EPREFIX}"'/etc/llvm,' \
- -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir)/llvm, \
- -i Makefile.config.in || die "Makefile.config sed failed"
-
- einfo "Fixing rpath and CFLAGS"
- sed -e 's,\$(RPATH) -Wl\,\$(\(ToolDir\|LibDir\)),$(RPATH) -Wl\,'"${EPREFIX}"/usr/$(get_libdir)/llvm, \
- -e '/OmitFramePointer/s/-fomit-frame-pointer//' \
- -i Makefile.rules || die "rpath sed failed"
-
- # Use system llc (from llvm ebuild) for tests
- sed -e "/^llc_props =/s/os.path.join(llvm_tools_dir, 'llc')/'llc'/" \
- -i tools/clang/test/lit.cfg || die "test path sed failed"
-
- # Automatically select active system GCC's libraries, bugs #406163 and #417913
- epatch "${FILESDIR}"/${PN}-3.1-gentoo-runtime-gcc-detection-v3.patch
-
- # Fix search paths on FreeBSD, bug #409269
- epatch "${FILESDIR}"/${PN}-3.1-gentoo-freebsd-fix-lib-path.patch
-
- # Fix regression caused by removal of USE=system-cxx-headers, bug #417541
- # Needs to be updated for 3.2
- #epatch "${FILESDIR}"/${PN}-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch
-
- # User patches
- epatch_user
-}
-
-src_configure() {
- local CONF_FLAGS="--enable-shared
- --with-optimize-option=
- $(use_enable !debug optimized)
- $(use_enable debug assertions)
- $(use_enable debug expensive-checks)"
-
- # Setup the search path to include the Prefix includes
- if use prefix ; then
- CONF_FLAGS="${CONF_FLAGS} \
- --with-c-include-dirs=${EPREFIX}/usr/include:/usr/include"
- fi
-
- if use multitarget; then
- CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
- else
- CONF_FLAGS="${CONF_FLAGS} --enable-targets=host,cpp"
- fi
-
- if use amd64; then
- CONF_FLAGS="${CONF_FLAGS} --enable-pic"
- fi
-
- # build with a suitable Python version
- python_export_best
-
- # clang prefers clang over gcc, so we may need to force that
- tc-export CC CXX
- econf ${CONF_FLAGS}
-}
-
-src_compile() {
- emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1 clang-only
-}
-
-src_test() {
- cd "${S}"/tools/clang || die "cd clang failed"
-
- echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
-
- if ! emake -j1 VERBOSE=1 test; then
- has test $FEATURES && die "Make test failed. See above for details."
- has test $FEATURES || eerror "Make test failed. See above for details."
- fi
-}
-
-src_install() {
- cd "${S}"/tools/clang || die "cd clang failed"
- emake KEEP_SYMBOLS=1 DESTDIR="${D}" install
-
- if use static-analyzer ; then
- dobin tools/scan-build/ccc-analyzer
- dosym ccc-analyzer /usr/bin/c++-analyzer
- dobin tools/scan-build/scan-build
-
- insinto /usr/share/${PN}
- doins tools/scan-build/scanview.css
- doins tools/scan-build/sorttable.js
- fi
-
- python_inst() {
- if use static-analyzer ; then
- pushd tools/scan-view >/dev/null || die
-
- python_doscript scan-view
-
- touch __init__.py || die
- python_moduleinto clang
- python_domodule __init__.py Reporter.py Resources ScanView.py startfile.py
-
- popd >/dev/null || die
- fi
-
- if use python ; then
- pushd bindings/python/clang >/dev/null || die
-
- python_moduleinto clang
- python_domodule __init__.py cindex.py enumerations.py
-
- popd >/dev/null || die
- fi
-
- # AddressSanitizer symbolizer (currently separate)
- python_doscript "${S}"/projects/compiler-rt/lib/asan/scripts/asan_symbolize.py
- }
- python_foreach_impl python_inst
-
- # Fix install_names on Darwin. The build system is too complicated
- # to just fix this, so we correct it post-install
- if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in libclang.dylib ; do
- ebegin "fixing install_name of $lib"
- install_name_tool -id "${EPREFIX}"/usr/lib/llvm/${lib} \
- "${ED}"/usr/lib/llvm/${lib}
- eend $?
- done
- for f in usr/bin/{c-index-test,clang} usr/lib/llvm/libclang.dylib ; do
- ebegin "fixing references in ${f##*/}"
- install_name_tool \
- -change "@rpath/libclang.dylib" \
- "${EPREFIX}"/usr/lib/llvm/libclang.dylib \
- -change "@executable_path/../lib/libLLVM-${PV}.dylib" \
- "${EPREFIX}"/usr/lib/llvm/libLLVM-${PV}.dylib \
- -change "${S}"/Release/lib/libclang.dylib \
- "${EPREFIX}"/usr/lib/llvm/libclang.dylib \
- "${ED}"/$f
- eend $?
- done
- fi
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- use kernel_FreeBSD && rm "${ED}"usr/$(get_libdir)/clang/${PV}/include/{arm_neon,std,float,iso,limits,tgmath,varargs}*.h
-}
diff --git a/sys-devel/clang/files/clang-2.7-fixdoc.patch b/sys-devel/clang/files/clang-2.7-fixdoc.patch
deleted file mode 100644
index 8058ec46bd8f..000000000000
--- a/sys-devel/clang/files/clang-2.7-fixdoc.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -Naur llvm-2.7.orig//tools/clang/docs/Makefile llvm-2.7/tools/clang/docs/Makefile
---- llvm-2.7.orig//tools/clang/docs/Makefile 2010-04-26 18:38:45.000000000 +0200
-+++ llvm-2.7/tools/clang/docs/Makefile 2010-04-26 18:41:08.000000000 +0200
-@@ -46,13 +46,12 @@
- # 'make generated BUILD_FOR_WEBSITE=1'
- generated:: doxygen
-
--install-html: $(PROJ_OBJ_DIR)/html.tar.gz
-+install-html:
- $(Echo) Installing HTML documentation
- $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html
- $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/img
- $(Verb) $(DataInstall) $(HTML) $(DESTDIR)$(PROJ_docsdir)/html
- # $(Verb) $(DataInstall) $(IMAGES) $(DESTDIR)$(PROJ_docsdir)/html/img
-- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(DESTDIR)$(PROJ_docsdir)
-
- $(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
- $(Echo) Packaging HTML documentation
-@@ -64,12 +63,11 @@
- install-doxygen: doxygen
- $(Echo) Installing doxygen documentation
- $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/doxygen
-- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(DESTDIR)$(PROJ_docsdir)
- $(Verb) cd $(PROJ_OBJ_DIR)/doxygen && \
- $(FIND) . -type f -exec \
- $(DataInstall) {} $(DESTDIR)$(PROJ_docsdir)/html/doxygen \;
-
--doxygen: regendoc $(PROJ_OBJ_DIR)/doxygen.tar.gz
-+doxygen: regendoc
-
- regendoc:
- $(Echo) Building doxygen documentation
-diff -Naur llvm-2.7.orig//tools/clang/docs/tools/Makefile llvm-2.7/tools/clang/docs/tools/Makefile
---- llvm-2.7.orig//tools/clang/docs/tools/Makefile 2010-04-26 18:38:45.000000000 +0200
-+++ llvm-2.7/tools/clang/docs/tools/Makefile 2010-04-26 18:41:29.000000000 +0200
-@@ -24,7 +24,7 @@
- CLANG_VERSION := trunk
-
- # If we are in BUILD_FOR_WEBSITE mode, default to the all target.
--all:: html man ps
-+all:: html man
-
- clean:
- rm -f pod2htm*.*~~ $(HTML) $(MAN) $(PS)
-@@ -58,7 +58,7 @@
- ifdef ONLY_MAN_DOCS
- INSTALL_TARGETS := install-man
- else
--INSTALL_TARGETS := install-html install-man install-ps
-+INSTALL_TARGETS := install-html install-man
- endif
-
- .SUFFIXES:
diff --git a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch b/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch
deleted file mode 100644
index 1053bf3642bc..000000000000
--- a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-cxx-paths-v2.patch
+++ /dev/null
@@ -1,188 +0,0 @@
-diff --git a/a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp b/b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
-index 1e282f2..1d6835b 100644
---- a/a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
-+++ b/b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
-@@ -2305,6 +2305,162 @@ void Linux::AddClangCXXStdlibIncludeArgs(const ArgList &DriverArgs,
- }
- }
-
-+void FreeBSD::AddClangSystemIncludeArgs(const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) const {
-+ const Driver &D = getDriver();
-+
-+ if (DriverArgs.hasArg(options::OPT_nostdinc))
-+ return;
-+
-+ if (!DriverArgs.hasArg(options::OPT_nostdlibinc))
-+ addSystemInclude(DriverArgs, CC1Args, D.SysRoot + "/usr/local/include");
-+
-+ if (!DriverArgs.hasArg(options::OPT_nobuiltininc)) {
-+ llvm::sys::Path P(D.ResourceDir);
-+ P.appendComponent("include");
-+ addSystemInclude(DriverArgs, CC1Args, P.str());
-+ }
-+
-+ if (DriverArgs.hasArg(options::OPT_nostdlibinc))
-+ return;
-+
-+ // Check for configure-time C include directories.
-+ StringRef CIncludeDirs(C_INCLUDE_DIRS);
-+ if (CIncludeDirs != "") {
-+ SmallVector<StringRef, 5> dirs;
-+ CIncludeDirs.split(dirs, ":");
-+ for (SmallVectorImpl<StringRef>::iterator I = dirs.begin(), E = dirs.end();
-+ I != E; ++I) {
-+ StringRef Prefix = llvm::sys::path::is_absolute(*I) ? D.SysRoot : "";
-+ addExternCSystemInclude(DriverArgs, CC1Args, Prefix + *I);
-+ }
-+ return;
-+ }
-+
-+ // Lacking those, try to detect the correct set of system includes for the
-+ // target triple.
-+
-+ // Implement generic Debian multiarch support.
-+ const StringRef X86_64MultiarchIncludeDirs[] = {
-+ "/usr/include/x86_64-linux-gnu",
-+
-+ // FIXME: These are older forms of multiarch. It's not clear that they're
-+ // in use in any released version of Debian, so we should consider
-+ // removing them.
-+ "/usr/include/i686-linux-gnu/64",
-+ "/usr/include/i486-linux-gnu/64"
-+ };
-+ const StringRef X86MultiarchIncludeDirs[] = {
-+ "/usr/include/i386-linux-gnu",
-+
-+ // FIXME: These are older forms of multiarch. It's not clear that they're
-+ // in use in any released version of Debian, so we should consider
-+ // removing them.
-+ "/usr/include/x86_64-linux-gnu/32",
-+ "/usr/include/i686-linux-gnu",
-+ "/usr/include/i486-linux-gnu"
-+ };
-+ const StringRef ARMMultiarchIncludeDirs[] = {
-+ "/usr/include/arm-linux-gnueabi"
-+ };
-+ const StringRef MIPSMultiarchIncludeDirs[] = {
-+ "/usr/include/mips-linux-gnu"
-+ };
-+ const StringRef MIPSELMultiarchIncludeDirs[] = {
-+ "/usr/include/mipsel-linux-gnu"
-+ };
-+ const StringRef PPCMultiarchIncludeDirs[] = {
-+ "/usr/include/powerpc-linux-gnu"
-+ };
-+ const StringRef PPC64MultiarchIncludeDirs[] = {
-+ "/usr/include/powerpc64-linux-gnu"
-+ };
-+ ArrayRef<StringRef> MultiarchIncludeDirs;
-+ if (getTriple().getArch() == llvm::Triple::x86_64) {
-+ MultiarchIncludeDirs = X86_64MultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::x86) {
-+ MultiarchIncludeDirs = X86MultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::arm) {
-+ MultiarchIncludeDirs = ARMMultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::mips) {
-+ MultiarchIncludeDirs = MIPSMultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::mipsel) {
-+ MultiarchIncludeDirs = MIPSELMultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::ppc) {
-+ MultiarchIncludeDirs = PPCMultiarchIncludeDirs;
-+ } else if (getTriple().getArch() == llvm::Triple::ppc64) {
-+ MultiarchIncludeDirs = PPC64MultiarchIncludeDirs;
-+ }
-+ for (ArrayRef<StringRef>::iterator I = MultiarchIncludeDirs.begin(),
-+ E = MultiarchIncludeDirs.end();
-+ I != E; ++I) {
-+ if (llvm::sys::fs::exists(D.SysRoot + *I)) {
-+ addExternCSystemInclude(DriverArgs, CC1Args, D.SysRoot + *I);
-+ break;
-+ }
-+ }
-+
-+ if (getTriple().getOS() == llvm::Triple::RTEMS)
-+ return;
-+
-+ // Add an include of '/include' directly. This isn't provided by default by
-+ // system GCCs, but is often used with cross-compiling GCCs, and harmless to
-+ // add even when Clang is acting as-if it were a system compiler.
-+ addExternCSystemInclude(DriverArgs, CC1Args, D.SysRoot + "/include");
-+
-+ addExternCSystemInclude(DriverArgs, CC1Args, D.SysRoot + "/usr/include");
-+}
-+
-+/// \brief Helper to add the thre variant paths for a libstdc++ installation.
-+/*static*/ bool FreeBSD::addLibStdCXXIncludePaths(Twine Base, Twine TargetArchDir,
-+ const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) {
-+ if (!llvm::sys::fs::exists(Base))
-+ return false;
-+ addSystemInclude(DriverArgs, CC1Args, Base);
-+ addSystemInclude(DriverArgs, CC1Args, Base + "/" + TargetArchDir);
-+ addSystemInclude(DriverArgs, CC1Args, Base + "/backward");
-+ return true;
-+}
-+
-+void FreeBSD::AddClangCXXStdlibIncludeArgs(const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) const {
-+ if (DriverArgs.hasArg(options::OPT_nostdlibinc) ||
-+ DriverArgs.hasArg(options::OPT_nostdincxx))
-+ return;
-+
-+ // Check if libc++ has been enabled and provide its include paths if so.
-+ if (GetCXXStdlibType(DriverArgs) == ToolChain::CST_Libcxx) {
-+ // libc++ is always installed at a fixed path on Linux currently.
-+ addSystemInclude(DriverArgs, CC1Args,
-+ getDriver().SysRoot + "/usr/include/c++/v1");
-+ return;
-+ }
-+
-+ // We need a detected GCC installation on Linux to provide libstdc++'s
-+ // headers. We handled the libc++ case above.
-+ if (!GCCInstallation.isValid())
-+ return;
-+
-+ // By default, look for the C++ headers in an include directory adjacent to
-+ // the lib directory of the GCC installation. Note that this is expect to be
-+ // equivalent to '/usr/include/c++/X.Y' in almost all cases.
-+ StringRef LibDir = GCCInstallation.getParentLibPath();
-+ StringRef InstallDir = GCCInstallation.getInstallPath();
-+ StringRef Version = GCCInstallation.getVersion();
-+ if (!addLibStdCXXIncludePaths(LibDir + "/../include/c++/" + Version,
-+ (GCCInstallation.getTriple().str() +
-+ GCCInstallation.getMultiarchSuffix()),
-+ DriverArgs, CC1Args)) {
-+ // Gentoo is weird and places its headers inside the GCC install, so if the
-+ // first attempt to find the headers fails, try this pattern.
-+ addLibStdCXXIncludePaths(InstallDir + "/include/g++-v4",
-+ (GCCInstallation.getTriple().str() +
-+ GCCInstallation.getMultiarchSuffix()),
-+ DriverArgs, CC1Args);
-+ }
-+}
-+
- /// DragonFly - DragonFly tool chain which can call as(1) and ld(1) directly.
-
- DragonFly::DragonFly(const Driver &D, const llvm::Triple& Triple, const ArgList &Args)
-diff --git a/a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.h b/b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.h
-index eaa6be1..bba891e 100644
---- a/a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.h
-+++ b/b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.h
-@@ -489,6 +489,16 @@ public:
-
- virtual Tool &SelectTool(const Compilation &C, const JobAction &JA,
- const ActionList &Inputs) const;
-+
-+ virtual void AddClangSystemIncludeArgs(const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) const;
-+ virtual void AddClangCXXStdlibIncludeArgs(const ArgList &DriverArgs,
-+ ArgStringList &CC1Args) const;
-+
-+private:
-+ static bool addLibStdCXXIncludePaths(Twine Base, Twine TargetArchDir,
-+ const ArgList &DriverArgs,
-+ ArgStringList &CC1Args);
- };
-
- class LLVM_LIBRARY_VISIBILITY NetBSD : public Generic_ELF {
diff --git a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch b/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch
deleted file mode 100644
index 702606f8a0ca..000000000000
--- a/sys-devel/clang/files/clang-3.1-gentoo-freebsd-fix-lib-path.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-This patch causes problem for multilib: GCCInstallation.getInstallPath() is
-empty in that case and 'clang -m32 foo.c' will put a -L with nothing after it
-but the .o file generated, effectively dropping it.
-With recent freebsd-lib versions, it is only needed for c++ with libstdc++,
-which is actually broken because clang++ cannot find the headers. it is fine
-with clang++ -stdlib=libc++.
-aballier@g.o
-
-diff -upNr a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
---- a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 04:08:48.393073000 -0400
-+++ b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 04:11:38.113153421 -0400
-@@ -1635,6 +1635,8 @@ FreeBSD::FreeBSD(const Driver &D, const
- getFilePaths().push_back(getDriver().SysRoot + "/usr/lib32");
- else
- getFilePaths().push_back(getDriver().SysRoot + "/usr/lib");
-+
-+ getFilePaths().push_back(GCCInstallation.getInstallPath());
- }
-
- Tool &FreeBSD::SelectTool(const Compilation &C, const JobAction &JA,
diff --git a/sys-devel/clang/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch b/sys-devel/clang/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
deleted file mode 100644
index 49f108533404..000000000000
--- a/sys-devel/clang/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -upNr a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp
---- a/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 03:32:31.593191000 -0400
-+++ b/llvm-3.1.src/tools/clang/lib/Driver/ToolChains.cpp 2012-05-24 03:38:31.733163513 -0400
-@@ -1145,6 +1145,25 @@ Generic_GCC::GCCInstallationDetector::GC
- Prefixes.push_back(D.InstalledDir + "/..");
- }
-
-+ llvm::OwningPtr<llvm::MemoryBuffer> File;
-+ for (unsigned k = 0, ke = CandidateTripleAliases.size(); k < ke; ++k) {
-+ if (!llvm::MemoryBuffer::getFile(D.SysRoot + "/etc/env.d/gcc/config-" + CandidateTripleAliases[k].str(), File))
-+ {
-+ bool Exists;
-+ const std::string VersionText = File.get()->getBuffer().rsplit('-').second.substr(0,5).str();
-+ const std::string GentooPath = D.SysRoot + "/usr/lib/gcc/" + CandidateTripleAliases[k].str() + "/" + VersionText;
-+ if (!llvm::sys::fs::exists(GentooPath + "/crtbegin.o", Exists) && Exists)
-+ {
-+ Version = GCCVersion::Parse(VersionText);
-+ GCCInstallPath = GentooPath;
-+ GCCParentLibPath = GCCInstallPath + "/../../..";
-+ GCCTriple.setTriple(CandidateTripleAliases[k]);
-+ IsValid = true;
-+ return;
-+ }
-+ }
-+ }
-+
- // Loop over the various components which exist and select the best GCC
- // installation available. GCC installs are ranked by version number.
- Version = GCCVersion::Parse("0.0.0");