summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-31 02:34:13 +0100
committerSam James <sam@gentoo.org>2023-08-31 02:34:39 +0100
commitac3e1265008b02455c9714b356d36fbbff2c019f (patch)
tree33cae5e0c4e82cf9b6f529409cd4a408b83fb31e /sys-devel/crossdev
parentdev-util/netsurf-buildsystem: update EAPI 7 -> 8, fix parallel builds (diff)
downloadgentoo-ac3e1265008b02455c9714b356d36fbbff2c019f.tar.gz
gentoo-ac3e1265008b02455c9714b356d36fbbff2c019f.tar.bz2
gentoo-ac3e1265008b02455c9714b356d36fbbff2c019f.zip
sys-devel/crossdev: add 20230831
Bug: https://bugs.gentoo.org/680652 Closes: https://bugs.gentoo.org/912849 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20230831.ebuild40
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild3
3 files changed, 42 insertions, 2 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index f65857fbe2f8..ad4c3f1ad0ce 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,2 +1,3 @@
DIST crossdev-20230321.tar.xz 29620 BLAKE2B a5070ccf8b5e4fd9a6f63f6a903126a6eb199d7dfdcfbe93f0917a66894c4eef2df5749c0fddaf564fe013b40a14d88b2686700034642fb1d876b51731964a49 SHA512 c300b506bb7ed4aa5d43601b37c8298367f6e5307a97b19a23f39e9559e54d2bfdb6e2b7a5fde4d5ff0b4a9b02c1b6f05be92d1857352db6cde9a469c9159e5f
DIST crossdev-20230616.tar.xz 29628 BLAKE2B 856f24f6afcdff8e9283ef9a90ff78312123aaad8386f7003d120b5c00cd74f6ba3a911979739434696ceedc13f432d05b60ef3349ade03aa4b49afa9e59a3fa SHA512 373ebd0c776a8d687bd11faa502a7b513f1e1dce5e310a1783349c7c2ad5b2b7e9bc51a59fdcb4414cb94faabc14ec3d723b187658ce35b4ebf73e4386d69930
+DIST crossdev-20230831.tar.xz 30792 BLAKE2B d8c738ff37dca4de64964fa51fec9981fd4b6ef101cd15d05a15ba8aa08d7e7fd3ad9dd56fdcd103b31fff2e458e94ffa22d586313f7c620fe7099cf0d9a662b SHA512 4e41e6ce37670f908d28adc76badd46532d89351240fe77e47aaf660f14da52320e30e55fee047464876bf7b6aab6968232d88fd8c69b62a3e4a83a8a8aad1dc
diff --git a/sys-devel/crossdev/crossdev-20230831.ebuild b/sys-devel/crossdev/crossdev-20230831.ebuild
new file mode 100644
index 000000000000..8938d96f9d54
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20230831.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/crossdev.git
+ https://github.com/gentoo/crossdev
+ "
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ app-shells/bash
+ sys-apps/gentoo-functions
+ sys-apps/config-site
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+
+ dodir /usr/share/config.site.d
+ mv "${ED}"/usr/share/config.site{,.d/80crossdev.conf} || die
+}
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index d15bf1ee5010..8938d96f9d54 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -10,8 +10,7 @@ if [[ ${PV} == "99999999" ]] ; then
https://github.com/gentoo/crossdev
"
else
- SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi