summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-02 20:09:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-02 20:22:09 +0200
commitf8527e2b19b62a25d2fc0c4f68e38db1010b7f5e (patch)
treed0fbdca0c77584c39f48b0d40ad8aa465cbd1569 /sys-devel/llvm-common
parentapp-shells/bash-completion: Bump to 2.7 (diff)
downloadgentoo-f8527e2b19b62a25d2fc0c4f68e38db1010b7f5e.tar.gz
gentoo-f8527e2b19b62a25d2fc0c4f68e38db1010b7f5e.tar.bz2
gentoo-f8527e2b19b62a25d2fc0c4f68e38db1010b7f5e.zip
app-vim/llvm-vim -> sys-devel/llvm-common
Rename llvm-vim package to llvm-common. It is going to be reused to include all the common files that are shared between multiple LLVM slots. This should also cut the pointless noise of our valuable users complaining that LLVM unconditionally depends on app-vim/* package.
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/Manifest2
-rw-r--r--sys-devel/llvm-common/llvm-common-4.0.0.ebuild29
-rw-r--r--sys-devel/llvm-common/llvm-common-4.0.1.ebuild29
-rw-r--r--sys-devel/llvm-common/llvm-common-9999.ebuild31
-rw-r--r--sys-devel/llvm-common/metadata.xml7
5 files changed, 98 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/Manifest b/sys-devel/llvm-common/Manifest
new file mode 100644
index 000000000000..a0a5bf2ee812
--- /dev/null
+++ b/sys-devel/llvm-common/Manifest
@@ -0,0 +1,2 @@
+DIST llvm-4.0.0.src.tar.xz 21016340 SHA256 8d10511df96e73b8ff9e7abbfb4d4d432edbdbe965f1f4f07afaf370b8a533be SHA512 cf681f0626ef6d568d951cdc3e143471a1d7715a0ba11e52aa273cf5d8d421e1357ef2645cc85879eaefcd577e99e74d07b01566825b3d0461171ef2cbfc7704 WHIRLPOOL 9783e8f47306c1deb2e114d4b46a7db9b0260b4965076345c88765413c5fc8e73fab5f88ae4903adbdea31406022948b16d32ae47d98f5def074509d5d794579
+DIST llvm-4.0.1.src.tar.xz 21065652 SHA256 da783db1f82d516791179fe103c71706046561f7972b18f0049242dee6712b51 SHA512 16adc39b34ddb628f81b171119a8e2a0e9138b25011e803ef0b688e2fbea116fc4953d3a1b61b90a98a75e33619f81566b7cb06a9a2ea4d04ac5e0eb303a2d1d WHIRLPOOL 1626ff270f7ce4801d02a0797b227fda9314ff5c0c01d653111599e9a4d2854c4d9edc3c698a7abee8d79d6bce8b18dc619fbced3c07ca610d44a248d65830cc
diff --git a/sys-devel/llvm-common/llvm-common-4.0.0.ebuild b/sys-devel/llvm-common/llvm-common-4.0.0.ebuild
new file mode 100644
index 000000000000..d307094d751b
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-4.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/llvm-${PV/_/}.src
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}
diff --git a/sys-devel/llvm-common/llvm-common-4.0.1.ebuild b/sys-devel/llvm-common/llvm-common-4.0.1.ebuild
new file mode 100644
index 000000000000..d307094d751b
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-4.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/llvm-${PV/_/}.src
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}
diff --git a/sys-devel/llvm-common/llvm-common-9999.ebuild b/sys-devel/llvm-common/llvm-common-9999.ebuild
new file mode 100644
index 000000000000..75124672bd72
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="http://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="http://llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}
diff --git a/sys-devel/llvm-common/metadata.xml b/sys-devel/llvm-common/metadata.xml
new file mode 100644
index 000000000000..89c4bdb96049
--- /dev/null
+++ b/sys-devel/llvm-common/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>llvm@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>