summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 16:01:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 17:51:51 +0100
commit58a15c0dc8d47e96b69c98b8025be25f3c4022b5 (patch)
tree56add912238c134e51406ef9cd15e2a6a0feae8e /sys-devel
parentsys-devel/llvm: Enable the linker plugin by default (diff)
downloadgentoo-58a15c0dc8d47e96b69c98b8025be25f3c4022b5.tar.gz
gentoo-58a15c0dc8d47e96b69c98b8025be25f3c4022b5.tar.bz2
gentoo-58a15c0dc8d47e96b69c98b8025be25f3c4022b5.zip
sys-devel/llvm: Rename USE={gold → binutils-plugin}
The plugin is now used by other binutils tools, and gold is no longer really relevant these days. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-13.0.0.9999.ebuild18
-rw-r--r--sys-devel/llvm/llvm-14.0.0.9999.ebuild18
-rw-r--r--sys-devel/llvm/metadata.xml3
3 files changed, 20 insertions, 19 deletions
diff --git a/sys-devel/llvm/llvm-13.0.0.9999.ebuild b/sys-devel/llvm/llvm-13.0.0.9999.ebuild
index a602eb65d6cf..f0bbf6805620 100644
--- a/sys-devel/llvm/llvm-13.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-13.0.0.9999.ebuild
@@ -19,14 +19,14 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="$(ver_cut 1)"
KEYWORDS=""
-IUSE="debug doc exegesis +gold libedit +libffi ncurses test xar xml z3
- kernel_Darwin"
+IUSE="+binutils-plugin debug doc exegesis libedit +libffi ncurses test xar xml
+ z3 kernel_Darwin"
RESTRICT="!test? ( test )"
RDEPEND="
sys-libs/zlib:0=[${MULTILIB_USEDEP}]
+ binutils-plugin? ( >=sys-devel/binutils-2.31.1-r4:*[plugins] )
exegesis? ( dev-libs/libpfm:= )
- gold? ( >=sys-devel/binutils-2.31.1-r4:*[plugins] )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=dev-libs/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )
@@ -34,7 +34,7 @@ RDEPEND="
xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
- gold? ( sys-libs/binutils-libs )"
+ binutils-plugin? ( sys-libs/binutils-libs )"
BDEPEND="
dev-lang/perl
>=dev-util/cmake-3.16
@@ -54,7 +54,7 @@ BDEPEND="
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
PDEPEND="sys-devel/llvm-common
- gold? ( >=sys-devel/llvmgold-${SLOT} )"
+ binutils-plugin? ( >=sys-devel/llvmgold-${SLOT} )"
LLVM_COMPONENTS=( llvm )
LLVM_MANPAGES=build
@@ -111,7 +111,7 @@ check_distribution_components() {
case ${l} in
# shared libs
- LLVM|LLVMgold)
+ LLVM|LLVMbinutils-plugin)
;;
# TableGen lib + deps
LLVMDemangle|LLVMSupport|LLVMTableGen)
@@ -308,8 +308,8 @@ get_distribution_components() {
docs-llvm-html
)
- use gold && out+=(
- LLVMgold
+ use binutils-plugin && out+=(
+ LLVMbinutils-plugin
)
fi
@@ -405,7 +405,7 @@ multilib_src_configure() {
-DLLVM_ENABLE_DOXYGEN=OFF
-DLLVM_INSTALL_UTILS=ON
)
- use gold && mycmakeargs+=(
+ use binutils-plugin && mycmakeargs+=(
-DLLVM_BINUTILS_INCDIR="${EPREFIX}"/usr/include
)
fi
diff --git a/sys-devel/llvm/llvm-14.0.0.9999.ebuild b/sys-devel/llvm/llvm-14.0.0.9999.ebuild
index a602eb65d6cf..f0bbf6805620 100644
--- a/sys-devel/llvm/llvm-14.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-14.0.0.9999.ebuild
@@ -19,14 +19,14 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="$(ver_cut 1)"
KEYWORDS=""
-IUSE="debug doc exegesis +gold libedit +libffi ncurses test xar xml z3
- kernel_Darwin"
+IUSE="+binutils-plugin debug doc exegesis libedit +libffi ncurses test xar xml
+ z3 kernel_Darwin"
RESTRICT="!test? ( test )"
RDEPEND="
sys-libs/zlib:0=[${MULTILIB_USEDEP}]
+ binutils-plugin? ( >=sys-devel/binutils-2.31.1-r4:*[plugins] )
exegesis? ( dev-libs/libpfm:= )
- gold? ( >=sys-devel/binutils-2.31.1-r4:*[plugins] )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=dev-libs/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )
@@ -34,7 +34,7 @@ RDEPEND="
xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
- gold? ( sys-libs/binutils-libs )"
+ binutils-plugin? ( sys-libs/binutils-libs )"
BDEPEND="
dev-lang/perl
>=dev-util/cmake-3.16
@@ -54,7 +54,7 @@ BDEPEND="
RDEPEND="${RDEPEND}
!sys-devel/llvm:0"
PDEPEND="sys-devel/llvm-common
- gold? ( >=sys-devel/llvmgold-${SLOT} )"
+ binutils-plugin? ( >=sys-devel/llvmgold-${SLOT} )"
LLVM_COMPONENTS=( llvm )
LLVM_MANPAGES=build
@@ -111,7 +111,7 @@ check_distribution_components() {
case ${l} in
# shared libs
- LLVM|LLVMgold)
+ LLVM|LLVMbinutils-plugin)
;;
# TableGen lib + deps
LLVMDemangle|LLVMSupport|LLVMTableGen)
@@ -308,8 +308,8 @@ get_distribution_components() {
docs-llvm-html
)
- use gold && out+=(
- LLVMgold
+ use binutils-plugin && out+=(
+ LLVMbinutils-plugin
)
fi
@@ -405,7 +405,7 @@ multilib_src_configure() {
-DLLVM_ENABLE_DOXYGEN=OFF
-DLLVM_INSTALL_UTILS=ON
)
- use gold && mycmakeargs+=(
+ use binutils-plugin && mycmakeargs+=(
-DLLVM_BINUTILS_INCDIR="${EPREFIX}"/usr/include
)
fi
diff --git a/sys-devel/llvm/metadata.xml b/sys-devel/llvm/metadata.xml
index b08267bacf75..c10c45dd8f21 100644
--- a/sys-devel/llvm/metadata.xml
+++ b/sys-devel/llvm/metadata.xml
@@ -10,10 +10,11 @@
3. A compiler infrastructure - LLVM is also a collection of source code that implements the language and compilation strategy. The primary components of the LLVM infrastructure are a GCC-based C and C++ front-end, a link-time optimization framework with a growing set of global and interprocedural analyses and transformations, static back-ends for many popular (and some obscure) architectures, a back-end which emits portable C code, and a Just-In-Time compilers for several architectures.
4. LLVM does not imply things that you would expect from a high-level virtual machine. It does not require garbage collection or run-time code generation (In fact, LLVM makes a great static compiler!). Note that optional LLVM components can be used to build high-level virtual machines and other systems that need these services.</longdescription>
<use>
+ <flag name="binutils-plugin">Build the binutils plugin</flag>
<flag name="doc">Build and install the HTML documentation and regenerate the man pages</flag>
<flag name="exegesis">Enable performance counter support for llvm-exegesis tool
that can be used to measure host machine instruction characteristics</flag>
- <flag name="gold">Build the gold linker plugin</flag>
+ <flag name="gold">Build the binutils plugin</flag>
<flag name="ncurses">Support querying terminal properties using ncurses' terminfo</flag>
<flag name="xar">Support dumping LLVM bitcode sections in Mach-O files
(uses <pkg>app-arch/xar</pkg>)</flag>