summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:28:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 05:28:35 +0100
commit83512a50b63d87b23cc1d47eb5392b4f5e15729e (patch)
tree164dacc8dc027272726995bf266b6b9f81d9e903 /sys-devel
parentsys-devel/llvm: Reenable EH/RTTI in *.9999 (diff)
downloadgentoo-83512a50b63d87b23cc1d47eb5392b4f5e15729e.tar.gz
gentoo-83512a50b63d87b23cc1d47eb5392b4f5e15729e.tar.bz2
gentoo-83512a50b63d87b23cc1d47eb5392b4f5e15729e.zip
sys-devel/clang: Reenable EH/RTTI in *.9999
This will also be the part of the next 16.x RC and 17.x snapshot. Bug: https://bugs.gentoo.org/884193 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-16.0.0.9999.ebuild4
-rw-r--r--sys-devel/clang/clang-17.0.0.9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-16.0.0.9999.ebuild b/sys-devel/clang/clang-16.0.0.9999.ebuild
index df441961397a..4c59778e088a 100644
--- a/sys-devel/clang/clang-16.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-16.0.0.9999.ebuild
@@ -270,6 +270,10 @@ multilib_src_configure() {
-DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ # these are not propagated reliably, so redefine them
+ -DLLVM_ENABLE_EH=ON
+ -DLLVM_ENABLE_RTTI=ON
+
-DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex !xml)
# libgomp support fails to find headers without explicit -I
# furthermore, it provides only syntax checking
diff --git a/sys-devel/clang/clang-17.0.0.9999.ebuild b/sys-devel/clang/clang-17.0.0.9999.ebuild
index df441961397a..4c59778e088a 100644
--- a/sys-devel/clang/clang-17.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-17.0.0.9999.ebuild
@@ -270,6 +270,10 @@ multilib_src_configure() {
-DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ # these are not propagated reliably, so redefine them
+ -DLLVM_ENABLE_EH=ON
+ -DLLVM_ENABLE_RTTI=ON
+
-DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex !xml)
# libgomp support fails to find headers without explicit -I
# furthermore, it provides only syntax checking