summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-09-30 22:37:33 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-09-30 22:52:02 +0100
commitbb6538b02a7df594bb1e91745f153944156492cc (patch)
tree80e668757e00dbf6153179f3f31f87332275b09a /sys-devel
parentsys-devel/gdb: drop support for fedora releases (diff)
downloadgentoo-bb6538b02a7df594bb1e91745f153944156492cc.tar.gz
gentoo-bb6538b02a7df594bb1e91745f153944156492cc.tar.bz2
gentoo-bb6538b02a7df594bb1e91745f153944156492cc.zip
sys-devel/gdb: enable verbose gdb build, bug #695936
While tracing missing tinfo detection Victor noticed lack of precise arguments to gdb's linker and compiler commands. Two issues fixed here: - restore default V=1 build in custome Makefile snippet - set --disable-dependency-tracking to top-level ./configure to reach ./configure files that actually define it. Top-level does not and thus tricks portage's econf() into not passing it on. Reported-by: Victor Mataré Bug: https://bugs.gentoo.org/695936 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/files/gdb-8.3.1-verbose-build.patch13
-rw-r--r--sys-devel/gdb/gdb-8.3.1.ebuild9
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild9
3 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/gdb/files/gdb-8.3.1-verbose-build.patch b/sys-devel/gdb/files/gdb-8.3.1-verbose-build.patch
new file mode 100644
index 000000000000..06aa6084d2d2
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-8.3.1-verbose-build.patch
@@ -0,0 +1,13 @@
+Enable verbose build. By default gdb ignores even --disable-silent-rules.
+Override verbosity back to non-silent.
+
+https://bugs.gentoo.org/695936
+--- a/gdb/silent-rules.mk
++++ b/gdb/silent-rules.mk
+@@ -1,5 +1,4 @@
+-# If V is undefined or V=0 is specified, use the silent/verbose/compact mode.
+-V ?= 0
++V ?= 1
+ ifeq ($(V),0)
+ ECHO_CXX = @echo " CXX $@";
+ ECHO_CXXLD = @echo " CXXLD $@";
diff --git a/sys-devel/gdb/gdb-8.3.1.ebuild b/sys-devel/gdb/gdb-8.3.1.ebuild
index 34f58f16fba2..41c20dc863f0 100644
--- a/sys-devel/gdb/gdb-8.3.1.ebuild
+++ b/sys-devel/gdb/gdb-8.3.1.ebuild
@@ -88,6 +88,10 @@ BDEPEND="
S=${WORKDIR}/${PN}-${MY_PV}
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -114,6 +118,11 @@ src_configure() {
strip-unsupported-flags
local myconf=(
+ # portage's econf() does not detect presence of --d-d-t
+ # because it greps only top-level ./configure. But not
+ # gnulib's or gdb's configure.
+ --disable-dependency-tracking
+
--with-pkgversion="$(gdb_branding)"
--with-bugurl='https://bugs.gentoo.org/'
--disable-werror
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 34f58f16fba2..41c20dc863f0 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -88,6 +88,10 @@ BDEPEND="
S=${WORKDIR}/${PN}-${MY_PV}
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -114,6 +118,11 @@ src_configure() {
strip-unsupported-flags
local myconf=(
+ # portage's econf() does not detect presence of --d-d-t
+ # because it greps only top-level ./configure. But not
+ # gnulib's or gdb's configure.
+ --disable-dependency-tracking
+
--with-pkgversion="$(gdb_branding)"
--with-bugurl='https://bugs.gentoo.org/'
--disable-werror