summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-30 15:26:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-30 15:26:56 +0200
commite1857def3989aa506b7bb7f08dca6ddaee1cd92e (patch)
tree20d232afccba4fa22090b1fca902d61d58e84247 /sys-devel
parentxfce-extra/thunar-archive-plugin: Bump to 0.5.0 (diff)
downloadgentoo-e1857def3989aa506b7bb7f08dca6ddaee1cd92e.tar.gz
gentoo-e1857def3989aa506b7bb7f08dca6ddaee1cd92e.tar.bz2
gentoo-e1857def3989aa506b7bb7f08dca6ddaee1cd92e.zip
sys-devel/clang-common: Fix S substitution
Variable reordering has caused the S substitution to be overwritten by the eclass logic. Rather than relying on a specific ordering, just update LLVM_COMPONENTS so that the default value works just fine. Closes: https://bugs.gentoo.org/841827 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-14.0.3.ebuild3
-rw-r--r--sys-devel/clang-common/clang-common-15.0.0.9999.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/sys-devel/clang-common/clang-common-14.0.3.ebuild b/sys-devel/clang-common/clang-common-14.0.3.ebuild
index 5f09f0a442dc..798f9e9fb858 100644
--- a/sys-devel/clang-common/clang-common-14.0.3.ebuild
+++ b/sys-devel/clang-common/clang-common-14.0.3.ebuild
@@ -7,7 +7,6 @@ inherit bash-completion-r1 llvm.org
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
-S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -17,7 +16,7 @@ PDEPEND="
sys-devel/clang:*
"
-LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
src_install() {
diff --git a/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild
index 46b53588191e..1285500128bb 100644
--- a/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.0.9999.ebuild
@@ -7,7 +7,6 @@ inherit bash-completion-r1 llvm.org
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
-S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -17,7 +16,7 @@ PDEPEND="
sys-devel/clang:*
"
-LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+LLVM_COMPONENTS=( clang/utils )
llvm.org_set_globals
src_install() {