summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-16 15:49:40 +0100
committerSam James <sam@gentoo.org>2023-07-16 15:51:46 +0100
commitf2311ffcbcd8dd3dd6873a65cfc3981ed9cf80a6 (patch)
treea07d5c9702cd8176a1b8c2e24a3d7de3d256cd8b /sys-devel
parentsys-libs/libcxx: default +static-libs on (diff)
downloadgentoo-f2311ffcbcd8dd3dd6873a65cfc3981ed9cf80a6.tar.gz
gentoo-f2311ffcbcd8dd3dd6873a65cfc3981ed9cf80a6.tar.bz2
gentoo-f2311ffcbcd8dd3dd6873a65cfc3981ed9cf80a6.zip
sys-devel/clang-common: depend on libcxx[static-libs] for USE=default-libcxx
This is expected to work out of the box. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.7-r7.ebuild (renamed from sys-devel/clang-common/clang-common-15.0.7-r6.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.6-r2.ebuild (renamed from sys-devel/clang-common/clang-common-16.0.6-r1.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_pre20230705-r1.ebuild (renamed from sys-devel/clang-common/clang-common-17.0.0_pre20230705.ebuild)2
4 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.7-r6.ebuild b/sys-devel/clang-common/clang-common-15.0.7-r7.ebuild
index 39ff858a4d06..7d9a04e76075 100644
--- a/sys-devel/clang-common/clang-common-15.0.7-r6.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.7-r7.ebuild
@@ -24,7 +24,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV} )
+ default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-16.0.6-r1.ebuild b/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
index 0b84c681c4f1..dd885c622784 100644
--- a/sys-devel/clang-common/clang-common-16.0.6-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.6-r2.ebuild
@@ -24,7 +24,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV} )
+ default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index 51e0f70c6470..9295c64406f2 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -24,7 +24,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV} )
+ default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )
diff --git a/sys-devel/clang-common/clang-common-17.0.0_pre20230705.ebuild b/sys-devel/clang-common/clang-common-17.0.0_pre20230705-r1.ebuild
index 51e0f70c6470..9295c64406f2 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_pre20230705.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_pre20230705-r1.ebuild
@@ -24,7 +24,7 @@ PDEPEND="
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
- default-libcxx? ( >=sys-libs/libcxx-${PV} )
+ default-libcxx? ( >=sys-libs/libcxx-${PV}[static-libs] )
!default-libcxx? ( sys-devel/gcc )
default-lld? ( sys-devel/lld )
!default-lld? ( sys-devel/binutils )