summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-01-05 19:05:33 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-05 19:06:02 +0100
commitf3a83b048a59a4325b5bc8872d340cbe6bb7968e (patch)
tree30d0c6e6f6b00deb6984a60771643347beda08e1 /sys-fs/erofs-utils/erofs-utils-1.3-r1.ebuild
parentdev-embedded/u-boot-tools: Stabilize 2021.07 arm64, #830607 (diff)
downloadgentoo-f3a83b048a59a4325b5bc8872d340cbe6bb7968e.tar.gz
gentoo-f3a83b048a59a4325b5bc8872d340cbe6bb7968e.tar.bz2
gentoo-f3a83b048a59a4325b5bc8872d340cbe6bb7968e.zip
sys-fs/erofs-utils: fix sys-fs/fuse dependency
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-fs/erofs-utils/erofs-utils-1.3-r1.ebuild')
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/erofs-utils/erofs-utils-1.3-r1.ebuild b/sys-fs/erofs-utils/erofs-utils-1.3-r1.ebuild
new file mode 100644
index 000000000000..749529d63343
--- /dev/null
+++ b/sys-fs/erofs-utils/erofs-utils-1.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Userspace tools for EROFS"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
+LICENSE="GPL-2+"
+
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/${PN}.git/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+IUSE="fuse +lz4 selinux +uuid"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0 )
+ lz4? ( app-arch/lz4:0= )
+ selinux? ( sys-libs/libselinux:0= )
+ uuid? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable lz4) \
+ $(use_with selinux) \
+ $(use_with uuid)
+}