summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-04-05 11:25:27 -0500
committerBen Kohler <bkohler@gentoo.org>2020-04-05 11:25:52 -0500
commit3384356d7e1079b2e2b7bc64761b27e48693f0a7 (patch)
treeef695ae07506cfb996b0d780feef3caf333d7667 /sys-fs/fatcat
parentdev-go/golicense: remove old (diff)
downloadgentoo-3384356d7e1079b2e2b7bc64761b27e48693f0a7.tar.gz
gentoo-3384356d7e1079b2e2b7bc64761b27e48693f0a7.tar.bz2
gentoo-3384356d7e1079b2e2b7bc64761b27e48693f0a7.zip
sys-fs/fatcat: add missing dep & include for musl
Closes: https://bugs.gentoo.org/716116 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-fs/fatcat')
-rw-r--r--sys-fs/fatcat/fatcat-1.1.0-r1.ebuild26
-rw-r--r--sys-fs/fatcat/files/fatcat-include-getopt.patch11
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild b/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..3fd6f3130447
--- /dev/null
+++ b/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="FAT filesystems explore, extract, repair, and forensic tool"
+HOMEPAGE="https://github.com/Gregwar/fatcat"
+SRC_URI="https://github.com/Gregwar/fatcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!elibc_glibc? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/fatcat-include-getopt.patch )
+
+src_install() {
+ cmake-utils_src_install
+ doman man/${PN}.1
+ dodoc docs/*.md
+}
diff --git a/sys-fs/fatcat/files/fatcat-include-getopt.patch b/sys-fs/fatcat/files/fatcat-include-getopt.patch
new file mode 100644
index 000000000000..a9c9094eceb3
--- /dev/null
+++ b/sys-fs/fatcat/files/fatcat-include-getopt.patch
@@ -0,0 +1,11 @@
+diff -ur a/src/fatcat.cpp b/src/fatcat.cpp
+--- a/src/fatcat.cpp 2020-04-05 11:12:55.773602065 -0500
++++ b/src/fatcat.cpp 2020-04-05 11:13:14.112132604 -0500
+@@ -8,6 +8,7 @@
+ #include "xgetopt/xgetopt.h"
+ #else
+ #include <argp.h>
++#include <getopt.h>
+ #endif
+ #endif
+